Download

Shadow disappears at close distances

Shadow fades off as two static meshes approach each other when using a movable light. How can I disable this? (Or what causes it?) This is most noticeable with flat/plane meshes.

Unreal-Proximity-Shadows

Edit: grammer, clarification

In the light shadow settings there’s a Shadow Bias setting which can adjust that
The reason for it is that due to how the dynamic shadows work there can be artifacts on objects at certain angles and that setting prevents the issue. However, it can make it to where objects can look like they’re floating because it cuts off the shadow where the object is in close proximity with the surface that is receiving the shadow.

1 Like

That was it, thank you for the tip and explanation!

ShadowBias