Download

Shadow clipping radius

I converted a tree mesh to nanite and now I get this weird black shadow radius. I tried few options and console commands but I’m not even sure what to look for in the settings.
This affects grass foliage and everything that’s supposed to be occluded by shadows that are cast from the nanite trees

Now I can get rid of the artifacting by enabling raytracing shadows but then I get only low poly shadow from the trees and it looks pretty unconvincing (I know this is a known limitation from documentation)

So does someone know if
A: there is a setting that can fix the non-raytraced clipping
B: there is a fix for nanite shadows and raytracing in UE5 coming at some point

Thanks for any help.

Well, I found a command that affects this issue

r.Shadow.Virtual.ResolutionLodBiasDirectional

default value of -0.5 seem to be very high and setting it to -2 helped in my case (although for cca 5-8fps slower performance)