Download

Shadow casting on volumetric fog with raytracing

I noticed that godrays, very cinematic and beautiful feature of volumetric fog is not possible while using raytracing.

My questions are:

  1. Is it something wrong with my computer? with my drivers, windows etc… or is this universal bug / feature / necessity ?
  2. Is there a workaround?

Steps to reproduce:

  • create blank project from 3rd person template, ray trace disabled, desktop quality

  • delete all except chairs and floor (I don’t think that this step is necessary, but I wanted to go really from scratch, so I just kept meshes as something to cast shadow later)

  • add directional light, set volumetric scattering intensity to 30 (just to boost the effect)

  • add exp.height fog. Fog density set to 2, height fall set to 2, volumetric fog checked enabled (just to boost the effect)
    = godrays are present

  • go to project settings, raytracing check to enabled
    restart required
    after restart godrays are still there but to truly enable raytracing (according to documentation https://docs.unrealengine.com/en-US/…ing/index.html) you have to also set RHI to DirectX12, so…

  • go to project setting - rhi -set it to DirectX12

  • restart engine and there are no godrays in fog

I also tried to enable distance field meshes, thought was, that maybe it is needed t to generate them so they could cast shadows, but no success… but I don’t understand distance field meshes truly so maybe that is the mistake?

I also noticed that Quixels foliage looks really bad with anything other than DiretX12, translucency feels just wrong. So in the end, one is left with a choice to have nice foliage or to have god rays.

Got lately same problem, have you found any solution?

I found a ‘half’ hack - if you disable ‘cast raytraced shadows’ on your light you suddenly get your volumetric shadows back - but obviously you’re then back to regular shadow maps for geometry which aren’t as good. So not really a solution at all.

My plan for the hack was to duplicate the light and have it only affect volumetrics, then turn off volumetrics on the main light and keep raytraced shadows on for it - but I haven’t figured that one out yet without doubling the amount of diffuse light in the scene.