Shadow Artifacts around smooth rounded corners


I am making many objects for a Arq scene I am building. I made a bunch of props which have smoothed rounded corners, like beds, or mattresses in sunbeds. I made the Bed in 3ds Max and I did a UV layout for the UVs of the textures. However, I am not texturing it using substance painter or anything like that, to save time I am using a material that has modified WorldAlignTexture function. This let me use multiple generic textures on objects quickly. (The modifications to the WorldAlignTexture functions is just an extra set of 3 scalar inputs for rotations on the X, Y, & Z axes)

Bed with UV channel 1

UV Channel 2

I then place the bed in the scene, and make sure the lightmap resolution is on the green side of things. I don’t do any special modifications to the build settings of the object where it generates the 2nd UV channel. I tried to fiddle with it, but all results where the same.

I then build the level with production quality and wait. In the end, I get this artifacts on these quads where the object get shadows but from nowhere. I am baffled by this and this just looks bad in many objects, as a lot of objects tend to make use of rounded corners.

How do I fix this?
Below are also post other examples where this is happening.

Hey did you tried tweaking/ disabling ambient occlusion settings ?