Download

Shaders not loading on Cinematics

Hello, I’ve been working with UE to make an Archviz Animation (It’s my first experience with the engine). I already did the camera set up with matinee (2 min long in total) and making some tests, my trees material won´t load in the entire 2 mins. They take like 8 seconds to load in the editor, but loads fine. Is there a way to precompile the shaders and store them for the cinematic? or somehow make matinee wait until it has finished loading the shaders and then starts?

Maybe I could just optimize the material, but I want to know another option if I have tons of trees or a complex shader that I would need to use.

I tried searching in google and this forum but couldn’t find anything similar. My trees are from the Foliage Starter Kit from user fighter5347
(https://forums.unrealengine.com/showthread.php?59812-FREE-Foliage-Starter-Kit)

Thanks in advance!

PS: Sorry if my english is bad, it’s not my native language.

Trees in the editor:
176d85e543cba4a9548432ae4231d68630fe7725.jpeg

Trees when recording Cinematic:
4cd48d7d8c351373a09e9b241813f73f818718c4.jpeg

I noticed this in 4.10, I think it might be a bug. I wanted to export a movie of a material I’d made that includes a good deal of custom code. I see some of the options for movie recording have changed since 4.9, but now my material displays as black. Maybe there’s a workaround, or I need to pick different options, I dunno. When I migrated the material to a 4.9 project, it rendered and recorded correctly.

Actually I’m using 4.9 … tomorrow I’ll try to upgrade the project to 4.10 and try, but I’m using some plugins that still aren’t for 4.10 (Substance is one of them) so I would need to find a workaround in 4.9

Tried opening the project in 4.10, but still the same problem.