Shaders compile after nearly every material alteration

Hey!
I had the same problem with the 4.1 version of the engine. It got solved, now we have the 4.2 version and it’s back again. I am just sitting here, playing with the material editor tools and the engine compiles thousands of shaders…

Old Thread:

New Video example:

Zip Download (recommended)

If the video quality is too low I can make a better one!

Hi Skullwing,

I watched the video and can see what you mean! Did this start occurring immediately after 4.2? Does this occur in a clean project with no additional content?

I am not sure I think this type of the bug was present in 4.1.1 too, I think they just removed that, it gets compiled if you add constants and so on. Unfortunately I didn’t work a lot with 4.1.1, I just recognized that the old bug was gone.

I saw today that it happens when I add devide, multiply and these components… and the absloute world position component… probably it happens with a lot more components, but these are the ones which I know who cause the material to compile.

And yes it happens in blank projects too.

Could you post your dxdiag here? Thank you!

The dxdiag.h?

I had to pack it because it was not allowed to upload it, it’s a zip file now.

Not exactly, The dxdiag I need is pretty easy to get, just follow these steps:

Go to start>search>cmd

Once you open the cmd prompt window, type dxdiag and hit enter. This will pullup the information I need. Thank you!

Oh, that is a problem ^^ Some time ago I screwed something up and the most of my cmd commands don’t work anymore, neither does this one.

Okay, fixed it.

As a test, I resetup my whole computer and installed the engine again, but I just had to add a panner and he started compiling again…

Hi Skullwing,

It appears that this is a known issue and it is currently under assessment to find a suitable fix.

Is there a workaround? I have the same issue in both 4.2.1 and 4.1.2.

At present no, we are assessing the bug and will let the public know when we do have a workaround or a fix available.

If this helps and you don’t know it, I couldn’t really test it, but I think this doesn’t appear on Windows 7, just on Windows 8.

Thank you for the information, I will add a note into the bug report!

Okay, I think I solved the problem for me. At the moment it works, I had to deactivate the real time protection of GData for the engine. I guess while it’s compiling shaders the engine changes a lot of files, which causes GData to slow everything down.

@Skullwing Can you elaborate? When you say GData, do you mean disabling Windows Defender from checking game data?

Ahh, thanks. Must be a different problem for me then, because I tried disabling Windows Defender with the same suspicion and had no success.

Not exactly, I never thought I have to explain to somebody what GData is. https://www.gdata.de/

http://imageshack.com/a/img820/6753/bbm4.png

Short: GData is an antivirus program, it’s real time protection is checking the files while the engine is compiling to make sure that everything is alright. This slows the whole system down, because it uses around 60% of the CPU. It’s unusual for GData to cause problems, due to that fact I didn’t think about it earlier.

Maybe you have another program installed which checks files?

Yeah, possibly, though I turned off everything I could think of and moved the project onto an SSD and it’s still doing the same thing… hmm…