Shader Compiling Really Slow

Ok, I’ve done it and it seems that it’s working. No more infinite shaders compile. Thank you!!! Hoping this will be the only problem I will find xD
I’ve uncommented it and changed from = 1 to = 0

Guys a quick speed up Tip. If u guys are only building many materials have only textures (I.e no material nodes ).
U can create a sample material with all texture types and create instances of it . For each version just change the texture part. If u do not understand what I meant comment below.

I really didn´t see diference

I was able to successfully compile an exe out of the code using VS 2017 and double-clicking the sln

The shadercompileworker is run with below normal priority, you can fix this by changing one line in the engine, but a much easier way is to just modify the shadercompileworker program to raise its own priority level on launch.

for example in ShaderCompilerWorker.cpp add this in the GuardedMainWrapper:


		/*or ... */
		HANDLE hproc = GetCurrentProcess();
		SetPriorityClass(hproc, new_level);


Hi, I’m new to the engine. Can you tell me how to do this in more detail? I can’t seem to find ShaderCompilerWorker.cpp. I’m running it on my Macbook Pro and the shader compilation seriously prevents anything from loading. Thanks!

Unreal Engine now has a [config option][1] for that, no need to recompile…



WorkerProcessPriority=-1 // change to 1