Download

Setup Swarm Using Hamachi?

Well I’ve spent the last several hours trying to get swarm to work over Hamachi. I’ve poured over documentation and forums to try and get it working, but in the end I was unsuccessful. First question. Is setting up swarm over hamachi even possible, or should I just stop trying? If it is possible, I’ll share my settings and errors, and hopefully one of you can see what I’m doing wrong.

This is the error that pops up in the error log when pinging remote agents.


1:37:45 PM:     PANDAGONSTUDIOS: IP address for this Agent cannot be verified - Coordinator and local mismatch or DNS inactive!

Also something that confuses me is the IP address for PANDAGON in the coordinator. PANDAGON’s IP is not the computer’s hamachi IP. It’s the computer’s actual external IP. However my computer’s (DANIEL) IP shows up as its hamachi IP in the coordinator.

In the swarm05 picture (the last attachment), I’m showing the result of Ping Remote Agents on the PANDAGON Agent. As you can see the PANDAGON agent is having problems connecting with DANIEL and itself…

I should also point out that in the coordinator pic PANDAGON was not assigned to DANIEL-PC’s job, but that’s not normal. Whenever I start building lights, it usually assigns the job to PANDAGON. But PANDAGON will never actually start working on the job, even when it says PANDAGON is available.

So yeah I have no idea of what is going on. I’ve tried every fix I found on the internet.

I’ve tried a few more things, and I’ve managed to get another computer to connect to mine (DANIEL). Everything seems to work fine, but I did have a question. When Swarm gets to Processing Mappings, the status for one of the computers stops (as seen in the attachment), but both computer’s cpu usage is still being maxed out. So I can only assume both computers are still working on the task. Has anyone else noticed this?

I’m pretty sure I know what is going on with the PANDAGON computer not working correctly. For some reason, PANDAGON’s swarm agent is using the computer’s IP address instead of the hamachi IP, and I don’t know how to change the IP address that the swarm agent uses.

I’d be interested to know this as well!

Not sure if you’ve seen this tutorial on setting up Swarm but it goes into how to set the SwarmAgent to use a specific IP:

Tutorial: Setting Up Swarm for Multiple Machines | Brian Goodsell - Environment Artwork

This tutorial covers LAN setup only the OP is looking for something over the internet.

What was your solution to this. Ideally this should work without Hamachi at all, as long as the external requests are being forwarded to the right internal machine and windows firewall is off it should work right? The other thing I heard was that you need to setup the local swarmcache folders as shares on the coordinator and remote machines. But that still doesn’t work for me.

From my limited experience, a real VPN solution is much more stable, e.g. OpenVPN. While it is harder to setup the first time, it’s once and for all.

Edit: SwarmAgent does have trouble with detecting the active network card. If switching to VPN doesn’t work for you, I can modify SwarmAgent for you.