Download

Setting up night lighting & odd problems

I’m trying to set up a small outdoor scene and want some nice ambient lighting from the moon (imagine a clear summer’s night with a full moon) - just a bit of gentle shadowing from the moon, and there will be a few small lights or emissive bits around. I’ve only seen one tutorial that was sort of straight-to-the-point, so I followed that and changed the sky sphere’s colours, flipped the directional light upside down and tuned the strength down.

Now, myriad of problems:

  1. When directional’s upside down, light leaking from bottom of meshes and obviously no shadows.
  2. Turn the DL downwards and tune it down instead - get the shadows and no leakage, but the skysphere is too bright and stars aren’t visible anymore.
  3. I cannot properly view the skysphere in the viewport (note: realtime is off, but turning it on doesn’t do much), whenever I face the camera to the moon, everything becomes pitch black around the scene (apart from the laser sharp moon). When I turn the camera around again, the lighting slowly creeps back in.
  4. Whenever I activate the rotator gizmo, it seems to work like a light and the scene goes pitch black while using it. Doesn’t happen with the scale or move gizmo.
  5. Moving camera in the Z axis seems to change the skysphere appearance, even though realtime isn’t on.

As you can imagine it’s a bit difficult to set up lighting when I cannot view the scene properly. The skysphere doesn’t stay in tact, though I have cloud speed set to 0, lighting quality set to production. I have no idea how to set this up properly, could anyone give me any tips on how to set up night time please and thanks?

Well, if anyone wants to know the answer to most of the problems, turn off eye adaptation, that’s apparently a thing. Auto Exposure (Eye Adaptation) | Unreal Engine Documentation I set both the min and max exposures to 0.1 and that seemed to do the trick.