Download

Setting the VR Tracking Level - Getting Started in VR with Unreal Engine Tutorial

Going through this tutorial, and I must say it has been a very helpful experience so far, but I’ve become stuck and am having difficulty troubleshooting my way out. Any help would be appreciated.

For anyone’s reference this concerns the 7 minute 39 second mark of the video “Setting the VR Tracking Level”. When I drag the “VRCamera Origin” to the Event Graph and try to link VR CameraOrigin to the VRCamera Origin on the Set HMDTracking Level I get the following error “Scene Component Object Reference is not compatible with Scene Capture Component Object Reference (by ref)”.

I feel like I have followed everything precisely but if anyone knows what I may have done wrong it would save my day. Thanks!

A Scene Component and a Scene Capture Component are different components in the engine. Is that a custom node? I cant find it in the palette or the documentation. If so, you’d just need to change that input from Scene Capture Component to Scene Component and it should work fine. If not, here’s another way to set a custom tracking height:

Given the hierarchy DefaultSceneRoot > VRCameraOrigin > Camera,

Could also be done like this, if you like optimized blueprints:

Just call this event on a keypress or buttonpress and add a value to ‘Nudge Amount’ and check the box to nudge up, leave it unchecked to nudge down.

The reason this works is because the camera is locked to your HMD, but its also a child of the VROrigin Scene Component, so moving the VROrigin will also move the Camera, in this case, up or down on the Z axis.

What I’d do is put one controller on the floor, then use the other controller with this event assigned to buttons (one with True for Up set to True and another set to False) and raise/lower the VROrigin until the controller on the floor matches the ground level in-game.

Hope this helps!

It helped greatly! I had incorrectly entered the input as “Scene Capture Component” when it should have been “Scene Component”. Thanks for getting me over that hurdle!

No worries! Happy to help :slight_smile: