Setting "Only Owner See" in blueprint breaks scene capture

I have a blueprint with a 2D scene capture component contained in it, and also a mesh component which I have set to “Only Owner See”. The scene capture component cannot see the mesh if this is set to true. This seems wrong?

Hey Hyperloop -

This depends how you have your BP setup. A typical Actor BP has an Owner of NONE so as Player 0 by default you are not the owner and therefore you will not see the object.

Thank You

Eric Ketchum

Hi Eric, thank you for your reply.

I’ve included a screenshot of my BP for clarity.

What you are saying re: the owners makes sense. Basically what I am trying to accomplish, is to allow the Capture Component to ‘see’ the object, but have the object be invisible to the player. The second half works great because, as you explained, the player isn’t the owner of the mesh so it’s invisible as expected.

The object is also invisible to the Capture Component which is not the desired behavior. Based on your reply, it sounds like the reason for that is that the blueprint actor has owner NONE.

I guess the key question is, can I make the Capture Component the 'owner of that mesh?

Alternatively, is there a different/more proper way to allow the Capture Component to ‘see’ something that is kept invisible to the player character? I would imagine that there are quite a few use cases for that, esp for rendering certain things to the HUD and the like.

Hey Hyperloop -

I have entered a request with our Engineers to look into why this particular objects is not seeing the Owner flags. It is TTP # 349471.

Thank You

Eric Ketchum

Hi Eric,

edit: made a bug report here - [4.7.3] 3D Widgets not Respecting "Only Owner See" in UI Space "Screen" mode - UI - Unreal Engine Forums

I understand this topic is somewhat old, but…

Would this also effect “Screen” rendered objects (i.e. a 3D “floating” UMG widget acting as HUD/helmet outline) showing up on remote machines? I have “Only Owner See” and “Screen” (instead of World) and everything works as I need, except when you go to 2 players, they can see each others HUD rendering on their screen as well.

This is particularly odd because I have the same settings on the Third Person bodies (rendered in World) and it works as I intend.


“I guess the key question is, can I make the Capture Component the 'owner of that mesh?”
No, because it’s a component and not an actor.
Additionally working around the problem with a child actor is impossible.
Only Owner See simply does not work with a SceneCaptureComponent2d, not even when you have 2 child actors and you set the capture to be the owner of the second child actor.

This is truly the first absolutely broken part of the engine I have found. Probably because they go about it in C++ for Fortnite

Oh that’s bed news for me .
I’m going over this problem right now in my asymmetrical VR game .
So do you think there’s no way of making a game like this where you can hide meshes from the VR player and show them on the VR spectator camera ?