Set Static Mesh to always be in front of particle?

I have a particle emitter behind a static mesh, and at most distances it all works perfectly for what I want - basically a glow around a sphere. However when I get a distance away, the particle starts overlapping the static mesh and appearing in front of it.

I know I could handle this a few ways, but I specifically want to just somehow set my meshes to ALWAYS overlap the particle if that’s possible? I feel like that must be here somewhere and pretty simple, I’m just not sure where exactly or if it is possible

I should add that one method I tried was adding a camera offset to the particle, but this only happens at the start and results in you seeing it’s in the wrong place when you move behind the object.

I could make it always update but I feel like that’s a waste of resources and there must be a simpler way to make it just always have priority

Hi Pinworm -

Have you tried to set the PSORTMODE View Proj Depth or Distance to View? This would be the first thing I would try as what you are describing sounds like a rendering sorting issue. The other thing I might look at is what type of material you have assigned to the particles. Are they translucent, additive or Opaque?

Let me know -

Thank You

Eric Ketchum

The PSORTMODE doesn’t seem to make a difference, all choice have the same result. Maybe to explain what I’m doing specifically, I have a static mesh sphere, and am using the Flare material that comes with the default explosion particle, expanding it, and then putting it inside the static mesh sphere in a blueprint, so that the edges work as an atmosphere.

Is there a better way I could do this? For now the effects works fine in the majority of my map, but if you get far enough away it seems to break down and the particle takes priority over the mesh in some areas. I’m not sure why this only happens when I get a certain distance away but works fine in 80% of areas

Hey Pinworm -

This is how I would setup an atmosphere shader for a planet. I would use two spheres one which is set to a slightly larger scale and with the following materials applied.

Atmosphere Material:

Planet Texture:

Final Results:

This may not be exactly what you are looking for and I would be happy to update this to get more of the results you are looking for, but I would need a screenshot of what you currently have.

Thank You

Eric Ketchum

Thank you so much, this is incredibly helpful and I learned a lot. If it’s not too much trouble I have just one more question - your spheres all look very very nice and smooth, as do the spheres in the previews. However, the sphere shape that comes with Unreal, appears really jagged and blocky. How did you get such nice looking spheres?

Thanks so much again!

Hey Pinworm -

Check you Engine Scalabilty settings in the viewport drop down menu. The above spheres are both the Editor Sphere, in Engine Content(in case you don’t’ see it, from the content browser, View >> Check Show Engine Content to True.) In general smoother spheres more edge loops in your modeling program, so if you are using the BSP sphere you would need to increase its tessellation.

Hope that gets you started -

Eric Ketchum