Set Max Walk Speed on Server getting corrected?

I am currently making a multiplayer game where a player speeds up when pressing a certain ability button. After looking up just about every thread I could possibly find, for everybody else changing the Max Walk Speed of the character on both client and server seemed to fix the issue. Maybe there was a recent change since that doesn’t work for me.

Although my goal is to change the speed for a few seconds, I am trying to just keep the speed up for more than a frame.
I have tried both of these implementations:

Implementation 1:

Implementation 2: Screenshot - e2e4553ea81917ad2abb96ed936c1a21 - Gyazo

On both implementations, I can tell the max walk speed was changed for maybe one frame, then immediately returns back to my default speed. I would think that changing the max speed on the server would be enough, but even after changing it on both client and server, the speed resets after a frame. I am considering updating the max walk speed every frame in Event Tick, but that just seems like it could create some bad correction as well.

Yeah, I just tried updating the max walk speed every frame in Event Tick, but when using that on a Client, the server seems to be correcting its position very frequently as it jitters constantly.

this is from 2019 and i still have the same problem in ue 4.25, when i try to change the max walk speed on client the character starts glitching but when trying on server it works fine.