SessionSearch->SearchResults.Num() is always "0".

I am following this basic guide and I have a problem when doing join.
How To Use Sessions In C++ - UE4: Guidebook.

I have debugged (the problem is that I don’t have the symbols for debugging editor) but I manage.
SessionSearch->SearchResults.Num() is always “0”.
The objects don’t come empty and I’ve made sure that the “Find” is being called correctly with respect to create. Exactly as in the guide.
For some reason, I can never join the other player’s game.

Although the debug on screen tells me OnSucces after completing the search, but it tells me 0 results.

I have tried:

  • bUseLobbiesIfAvailable to true (doesn’t make much sense)
  • Run the application with the antivirus disabled (it hasn’t worked either)

I think it’s a session problem. I changed:

  • GameSessionName → NAME_GameSession
  • Player->GetPreferredUniqueNetId() → Player->GetPreferredUniqueNetId().GetUniqueNetId()
    nothing happened because it doesn’t work

The first player can create without problems to enter the game, but the second player, simply cannot find the session or so it seems.

In blueprint it works at the moment and without problems…
​Is there something that has changed in C++?

@Drakgoku Hi. I faced the same issue. Did you find solution?

1 Like

For me the issue was when running from editor is giving the session result 0. Then I run the map from batch file using unreal commands it works fine there.