Server Travel

Hi, if someone had the same Problem to test the servertravel console command here
is my solution.

I took me three days to get the Server Travel working in Version 4.19.0 Preview6

  • In GameMode Blueprint spell the command → servertravel MapName(i also tested it in GameInstance Blueprint) you can check use seamless travel here in Default Settings of your GameMode.
  • In Change Play Mode & Play Settings → Advanced Settings… Set Play as Client.
  • In EditorSettings → Multiplayer Settings → Uncheck use Single Process.
  • In Project Settings make sure all Maps and Mods are filled out and set a Default Game Mode.
  • Make sure all your Levels have the right GameModes and PlayerControlles set under World Settings.

Now Play as Standalone Game.

If you dont use steam Subsystem in your DefaultEngine.ini you can add:


Thanks! My issue was I didn’t realize that servertravel only works in a Standalone game instance, which was stated in this tutorial and I couldn’t find a similar statement in the documentation. I didn’t have to uncheck use single process, though.

Thanks! Solved me problem. I forgot using standalone before