Serious conversion issue from 4.19 to 4.20 (bug?)

Hello community,

since I don’t know if this is a bug, or my fault, I decided to try the forums first.

here is the thing:
I really need to use the 4.20 because of it’s DOF rework, it tremendously affects my stills and animations.

I was using 4.19 to build the lightmaps with the gpu lightmass made by luoshuang and downloaded 4.20. Everything looks perfect except the circular dof with it’s sharp edges.

So I loaded the project in 4.20, it complained about 2 missing plugins, since the’re not integrated yet - datasmith and substance.

But the scene opens and looks fairly good except this weird thingy

as you can see the floor panel next to the ladder has switched lightmaps with the one in fornt of the shelf. there are more objects in the scene behaving like that - but not most of them, just a few.

random objects have switched lightmaps on different material IDs, but not every object, just (imho) randomly chosen ones. as you can see, the lightmaps on the crates in the background or the pillows are correct and good looking.

is this a bug or am I doing something wrong, better to say, is there a way to fix it? I can’t bake the lightmaps in 4.20 because the gpu lightmass bakery is not available on 4.20 and i doubt it will be (soon).

as this is crucial, please try to help as much as possible.

thank you guys,
michael

update: i installed the 4.20 final and tried again, still no success. the datasmith imorter plugin is up and running now. please help

I took screenshots from all the objects I could find, which are misbehaving:

247837-2018-07-19-14-13-33-window.jpg

the table is actually white.

there are lightmaps as you can see, but somehow they’re not on the right subobject. the wooden panels are not single objects, theyre merged together to a single object with different material IDs, but so are a lot of other objects, that behave well.

here are some other objects:

247840-2018-07-19-14-14-17-window.jpg

this is also annoying, the black wall should have the same concrete texture as the wall on the right, on the bump and specular map you can see, it has the same texture but the lightmap is completely black.

247861-2018-07-19-14-14-48-window.jpg

update:

I loaded an earlier version of the project into the new 4.20 - NO problems. Everything looks as it should. But it’s from 10 days ago and i really dont want to lose 10 days of work.

Hello,

We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

I have a problem opening v4.19 proyect when switch to 4.20 engine:
"
Visual Studio:
El subproceso 0x32a0 terminó con código 0 (0x0).
El subproceso 0x2e90 terminó con código 0 (0x0).
El subproceso 0x1c98 terminó con código 0 (0x0).
El subproceso 0x63c terminó con código 0 (0x0).
"
(And the loading Editor is frozen on: Initializing… 45%)

Ok, I think is because the *.ini files I tested it.
Using config ini files from a 4.19 proyect doesn’t work on 4.20 (Editor doesn’t LOAD)

I just recently ran into the same issue using production bake. When baking in preview mode everything seems to look fine. Were you able to figure out a solution to this?

Unfortunately no, the epic support i had massive email traffic with wasn’t able to help out. They blamed the GPU Lightmass, but it occured also when using regular baking. Since the GPU Lightmass is now available for 4.20.1 it’s not longer an issue for us because it goes away when you bake the lighting again in 4.20.

Have you tried baking the light in 4.20 again?