Download

Sequencer camera spins around after 180 degrees

Is this a bug? Doing a simple fly through of a interior amd of i rotate the camer past 180 degrees, it does a whole 360. Any fix?

I FIXED OT THROUGHT the curve editor but is there a way to prevent this in the first place?

Nope it’s a bug.

Ahhhh! Good to know. Its annoying. I just dl 4.18… wonder if its fixed.

I also wanted to update to 4.18 to see if its fixed, do you have an update @syrom?

I dl it but havent gotten to use it with animation. Ill try it out in about 3 hours when I am free.

Ok… just tried it. If its a bug, its still there. It flipped 360 again. :confused:

Ah yeah, I downloaded the latest as well to try it. It’s very unfortunate that this happens.

Well it’s not a bug but a thing called Gimbal Lock

More or less it’s a thing that will be there anytime there is three angles of rotation to deal with referencing world space. The usual fix is not to free hand the camera directly but attach the camera to a custom Gimbal, dolly, or spline track.

Hmm… i read something around those lines. Will look into it.

It seems that the latest update (4.18) has found a fix for this issue, or at least the interpolations are generally much better. Are you still having trouble? In 4.17, I tried to do a simple camera Z rotation around a character or object and the camera would rotate counter-clockwise. Now it successfully goes around the character given the shortest distances of my keyframes.

If this update didn’t resolve for you, I tried a couple of workarounds as well. Manually going into the curve editor is tedious and so is keyframing through the viewport but those were my first attempts. What ended up being a feasible solution for me was attaching the camera to a rig (rail/crane). It allows for you to gain more control in the camera rotations. As @FrankieV explained, it seems like the best solution to this issue.

It’s not gimbal lock. It happens even with only one axis of rotation. The bug has to do with faulty interpolation of positive to negative numbers (since they for some reason use -180 to 180 instead of 0 to 360. Instead of going through the shortest rotation path the rotation is forced to go through the positive/negative side until it reaches the other side. It has nothing to do with gimbal lock.

Wait… so its a bug? I have noticed the positive to negative effect that triggers it.

Yes, it’s a bug. It’s on the issue tracker with a target fix for 4.19 (which will hopefully happen).

So comfirmed. Ok… good to know.

A current workaround I found for this is to create a keyframe on the frame before the flipping, and reset the rotation to positive or negative space depending on which one works. Essentially all of the flipping happens in a single frame and it’s invisible :slight_smile:

Noticed this the other day. I worked around the problem by rotating the camera in 90 degree steps. Have the same problem in 3ds Max as well

I’m having the same issue in 4.19.1… So it is not fixed yet… I want to rotate a cube 90 degrees every time I press a button… but it doesn’t work, no matter if the cube rotates clockwise or counterclokwise.

Still not fixed wow

from roadmap as done for 4.20… is this the one?

[FONT=Helvetica Neue]Sequencer now supports continuous euler angle changes when changing rotations. Euler angles are no longer limited to -180,180, which is necessary to avoid flips.