Self-Shadows does not work

I am faced a problem with self shadowing
It looks like “self shadows only” check box does nothing(
Or maybe I am missing something?

This issue present only on my version of editor(4.10.2) ?

Is the mobility set to static? It has to or the flag won’t work.

Ive just tried it, it doesnt change anything(
But if it does, it is strange…self shadowing only works with static lighting? Hmm…


Maybe anyone faced this issue too?

The “self shadow only” makes the mesh only cast shadows on itself, and no other objects.

Yep, you just described how it should works, but it doesn’t as you can see on screenshot above
Here is better illustration of how it should work

New info, just tried 4.11
Self shadows works only for Directional light and not for point or spot, is it correct? Some kind of limitation?

That image just explains what self shadowing is. The checkbox on your first screenshot says “self shadow ONLY”, which makes the object not cast shadows on any other actors. And that exactly what it does when I use it.
Self shadowing should work right out of the box, I have no idea why it doesn’t work for you.

It works for you?
Cloud you pleaaasseee grab this chair rotate it and put only one point light near it, and try self shadowing, because for me it works only with directional light

Working as intended from what I can see.

Light is set to movable and placed directly above the middle chair.
All three chairs are using self shadowing only
Test with 4.11

The shadowed areas of each chair is only self shadowing itself and not based on the light casting shadows.


Sorry, everybody probably tired of me, with self shadowing problem
Maybe I am misunderstanding the term of self shadowing, because what I have now, and all I want is to archive the same result for all light types as it shown on last screen with directional light

From what I can see, your first picture looks correct. The shadow from the foot of the chair shadows part of the underside of the seat, and also a small part of the back of the backsupport. In other words the chair is shadowing itself.

Thanks for the answer, which one of them? added more organized version for better visibility

Bump, tried 4.11 today, still the same.
So maybe anyone know how to achive the following effect with spot and point lights

Bump, anyone?

Did a quick test and indeed looks like it doesn’t work. Bug?

Finally)) I am not alone with this issue, hope epic will notice it now

This is a super old thread, but it’s the first thing that came up when I was searching for info on the “Self Shadow Only” checkbox.

It seems like even in 4.19 the self shadowing option doesn’t work for anything other than directional lights, which is pretty darn limiting for any levels taking place indoors lit exclusively with point and spot lights.

Even Tim Hobson’s post #11 doesn’t show any actual self shadowing from the arms or legs that I can see.

I’ve made sure to set everything to Moveable - the point or spot light and the dynamic object I’m trying to make self shadow, but the object never produces shadows on itself.

Also running into this issue, but what doesn’t make sense is that with Self-Shadow Only disabled, your chair self-shadows, while on my end I’m seeing two different behaviors with the same setting (Self-Shadow Only disabled) on two meshes lit with Spot Light. In this first image the bowl of fruit is a single mesh, the fruit partially casts a shadow on itself. In the second image the brick wall with breaker box and steel armatures is one mesh, point light casts shadows from these features of the mesh on itself. What explains that and how to fix it?