Download

Selective MotionBlur for Particle Effects? (Resolved)

Im using Particle Effects to draw navigation lines, and weapon aim lines.
But while moving they get blurred to the point that they are no longer or barely visible.
I need them to remain “crisp” and bright while moving, for the purpose of accurate visual feedback to the player.
I tried setting Motion Blur in the post process volume to 0, but it did not help. Also I would like other particle effects that aren’t meant to be player feedback to retain motion blur(like explosions or projectile trails).

Any help with this would be much appreciated.

Are you sure it’s not the anti-aliasing doing this? If you set motion blur to 0 it should be disabled.

Hmmm. Ok I set the Editor’s AA setting to “low” and the effects became crisp and visible while moving.

…So is there a way to ensure the particle effects are crisp and clear with a higher AA setting?
I don’t want the player to have to chose between visible feedback and superior AA settings.

Checking this option in the material of the particles should give you the desired effect.

That worked beautifully, thank you.