"Select All With Same Material" does not work for me

often I need the function “Select All With Same Material” to apply a specific scale and alignment to my surfaces, but when I use it, it selects all brushes in my map insteat of these of the selected material. Sometimes it works and sometimes not but I wasn’t able to reproduce this yet and hope for a tip what I’m doing wrong :slight_smile:
Im using the latest Unreal Tournament Editor btw.
Two screens to show the problem:

I think now, this is a bug somwhere in the relevant function used for this but my C++ skills are not good enough to really analyse this one. The function being used is “void UUnrealEdEngine::edactSelectMatchingMaterial()” in UnrealTournament/Engine/Source/Editor/UnrealEd/Private/EditorActor.cpp

Heres another screen which shows two situations, one works as expected and the other one doesn’t.

  1. “Here, it works” shows the surface where the function “Select All With Same Material” works as expected.
  2. “Here, it doesn’t work” shows the surface where this function doesn’t work and selects any brush in my map.

Both brushes have the same material and are additive…

Still no news on this :frowning: ? I really badly still need this feature. If theres anything I could provide, I would do it…

Hey EisWiesel,

I just tested this issue in a new blank project using 4.9.2 and 4.10.2, which are our more recent engine releases.

Matching Material Selection

I have found there are a few ways to select all with matching materials. You can select a BSP and press the Shift+T command, you can select the BSP and choose the Select > Select Matching Material under the Geometry section.

You can also use the right click menu, as you are showing in your example post.

Both of these worked correctly for me in either engine version. Try testing this out in one of our newer releases to see if it is working correctly for you there.


Hey AndrewHurley,
I just tried the option of your first screen using Select → Select Matching Material under the geometry Section of a Brush and it works now for the first time :slight_smile: Seems like I was too stupid to find it… thx a lot for your effort.
However the second method, using the contextmenu like in my first post still doesnt work. Using the most recent precompiled UT Editor Version: 4.8.0-2771652+++depot+UE4-UT-Releases.

That will speed up my work a lot, thx again :slight_smile: