Sculpt Tool Broken. UE4 Rendered Useless

I’ve had this issue for a bout one week now and I’m realising if I can’t find a fix then Unreal Engine is completely useless to me.

I can no longer sculpt any landscape. existing or new. Everything is square and pointy and sharp and ■■■■■■.
When I noticed the issue I was in a project using a free heightmap from World Machine - maximum resolution of 513.

Any research led me to seek out heightmaps with higher resolution, read many documents on quad size and components and yada yada.
I decided I’d just keep it simple, I’m an artist, I want to see my vision quickly. The Sculpt feature was working when I last made a new landscape so I’ll just sculpt exactly what I want from scratch.


I get this BS pointy jagged trash that’s supposed to be curved, even on a new landscape:

Ok then, new project. No.
New Level. No.

Ok I’ll reinstall the ■■■■ engine if I have to… Still no.
I’ll try in a previous version of the engine… No.

I will uninstall and reinstall the engine. No.

You have left me with no choice, I will reinstall God ■■■■ Windows. I am a completely different person that this engine has never met and guess what after all that it still doesn’t forrrrrking worrkkkkkk.

Please, can anyone tell me what is going on here before I give up on wanting to create anything ever again.

Hi, just tried it on my end and it seems to me that this is not related to your computer

So just using the sculpt tool with the default heightmap resolution (I set the viewmode to detail lightning to better see the sharp edges)

Using the smooth tool (under the landscape sculpt tools) afterward removes it, but in my opinion it might be a pain smoothing it manually afterwards…

Using double resolution of the landscape heightmap (just set the x and y scale to 50) without any smoothing

But I would be careful about using a higher resolution since this will increase memory usage and might also lead to other performance issues

And using a heightmap created in an external program. In the external program I added a denoise on top, to smooth those sharp edges.

So if you want to manually sculpt the landscape it seems to me that you would need the smooth tool to smooth those sharp edges. I don’t know world machine but I think you should be able to add a denoise on top there too.

Else maybe using landmass and blueprint brushes also solves this, but I never used it so I can’t tell Landscape Blueprint Brushes | Unreal Engine Documentation

That’s strange, I can see the image here. I’ll try and put it in this comment just so you can see.

Looks like a long road to recovering the functionality I’m certain it once had - I’m questioning my memory now.

Thanks for your help. I’ll be sure to post any further information I find for others having the same issue.

Hi chrudimer, thanks for trying to help.

The following image is the result of a new project, basic create new landscape, with the resolution doubled. Using the default sculpt tool settings with various brush sizes only. Holding cursor in place and holding left mouse button.
I am unable to then smooth as at a certain size the brush has zero effect. Having the brush large enough to alter the terrain results in complete loss of initial shape. On larger sculpted ares where I can smooth, the pointed edges persist…

I also tried with an already made landscape, specifically the Spring Landscape free this month. I experienced the same results.

Before I even knew what a heightmap was I used the standard sculpt tool and settings to simply sculpt curved hills and mounds etc. Something has changed.

Thanks again.

Did you forgot to add the image? :slight_smile:

I also tried with an already made
landscape, specifically the Spring
Landscape free this month. I
experienced the same results.

Yes it won’t make any difference, since it is how the sculpt tool is working that causes the sharp edges.

And I set the strength of the smooth tool to something very low, so around 0,0001 - 0.0003
But yeah, this might be a pain to get correct, so to smooth it but not change the landscape.

But the problem is that I don’t use the sculpt tool right now, and I don’t know when I might need it again, so I can’t really help you there.
Basically what might help you

(1) When you sculpt, use a greater falloff and don’t use too small brush sizes

(2) Maybe look into landmass and blueprint brushes and try using those instead of sculpting for most of the time

You’re right in thinking the sculpt tool used to work in older versions of the engine. We created a very detailed and realistic terrain using only UE tools 3 years ago. Now we have the same issue as you even when importing pre-made terrain maps. I’m not sure why it was changed.

Hey, sorry to hear you’re experiencing it too. These days I don’t do so much sculpting in UE4 however, I do dial my Landscape LOD to 0 instead of -1. This makes it more workable for me, hope that helps.