Download

Sculpt Metahuman Face on Blender, then import back for livelink

Hi there,

First of all, apologize if this has been asked before but I can’t seem to find a similar thread to the specific question. If there’s a duplicate I will remove the post.

I am new to Unreal Engine and been experimenting with metahuman, especially customizing it beyond the website, through 3D software that I’m familiar with, Blender.


UPDATES

Managed to get it working thanks to thehemsley

Here are the steps:

  1. Do the metahuman, download on quixel, import on unreal, export the FBX of face
  2. Convert the FBX with Autodesk FBX converter to fix the shape keys. DOWNLOAD HERE I used FBX 2013.3 Converter for Windows 64-bit
  3. Import to Blender and make sure the shape keys are there. Sculpt it, with minimal damage to the weight paint so don’t add faces
  4. Rotate the armature mesh 90 degrees so it faces the ground
  5. Export to FBX with some settings

    Under Transform: -Z Forward, Y Up, Check Apply Unit, Use Space Transform
    Under Geometry, Unchecked Apply Modifiers

  6. On Unreal, make sure you duplicate the project file
  7. Go to your Metahuman Blueprint, find the FaceMesh mesh
  8. Click Reimport Base Mesh with New File and find the object
  9. Double check if your animation blueprint is correct, it should be Face_AnimeBP_C
  10. Make sure your Live Link is setup and it should be good!

OLD CASE
I was so happy that I wanted to improve more of the face mesh to make it more like the model I want however, down the line I messed up and TL;DR, the project file is messed up, all the bones become missing and the mesh were all over the place.

Since then I have been trying to re-do it. Here’s what I have tried so far and where I have left off.

  1. Do the metahuman, download on quixel, import on unreal, export the FBX of face
  2. Convert the FBX with Autodesk FBX converter to fix the shape keys
  3. Import to Blender with shape keys, sculpt it, with minimal damage to the weight paint
  4. Export to FBX with some settings

    Under Transform: X-Forward, Z Up
    Under Armature, Primary Bone X Axis, Secondary Bone, X Axis
    Unchecked “Add Leaf Bones”

  5. Import to Unreal with some settings:

    Import Morph Targets
    Import Rotation, Z-90
    I follow the settings recommended by this guy here

  6. Swap the Face Mesh with the new mesh and Skeleton
  7. Retarget the Face_AnimBP to the new Skeleton
  8. And this is the final error.

For some reason, the mesh turns upside down and looks weird, here’s it playing with the animation sample from AR kit

When you export from unreal, in the export settings do you have the export morph targets box checked, this should be unchecked, then convert using the FBX converter and when making edits on the face mesh in blender do you have the basis shape key selected in the shape keys. Also in the import to unreal are you selecting the face skeleton rather than the metahuman skeleton?

When you export from unreal, in the export settings do you have the export morph targets box checked, this should be unchecked, then convert using the FBX converter

I checked EXPORT MORPH TARGET otherwise the shape keys are missing.
I tried exporting it again with it unchecked and re-import. On blender the shape keys are missing. And when I import back to Unreal. It has the same issue. HERE
I noticed the vertices count changes from the original. Not sure if that’s why and if this is fixable Comparisson

and when making edits on the face mesh in blender do you have the basis shape key selected in the shape keys.

Yup I did it on the basis

Also in the import to unreal are you selecting the face skeleton rather than the metahuman skeleton?

I created an own skeleton (based on the face rig), and re-target the blueprint to the new skeleton
I also tried just using the original skeleton. Both works but still have the same issue.

Hi, yeah for some reason in my notes I had put down to uncheck the morph targets box but you’re correct you need it checked. I have just managed to recreate your issue and also fix it, it appears to have to do with the rotation export options. I’m also reusing the original face mesh and duplicating it and then reimporting the face mesh with a new file, if the orientation isn’t correct it comes in deformed.

Before export from blender I rotate the mesh and armature 90 degrees so the face is facing the ground plane and my export settings are default;

-Z Forward
Y Up
And also untick apply modifiers in the geometry.

If you have no luck I will put together some screenshots and my process m. With this method you have to reassign the materials on import.

I tried the same settings as you mentioned.

The mesh isn’t broken so that’s great! However the facial rig doesn’t register my face and the head is being tilted backwards further than normal

Seems like I still missing some steps… Here’s the setting I did

Rotate the bone and mesh downwards so it faces ground ✓
Under Transform: -Z-Forward, Y Up
Unchecked “Add Leaf Bones”
Unchecked “Use Space Transform”
Unchecked “Apply Modifiers”

On Unreal

Checked Import Morph Targets
No rotation added

Duplicate the original face mesh that came with your MH and then open that new duplicate mesh, at the top of the screen you will see a reimport mesh button, dial down the menus for that and select reimport mesh from new file, now select your mesh fbx from where you exported from blender, you will get a texture dialog screen where you need to match up the texture names. Once imported reassign the control rig to the face mesh and all should be good.
If your mesh is slightly off I would suspect that it wasn’t rotated exactly 90 degrees or may have been previously moved without knowing. Let me know if that works.

Awesome! That works.

I guess what’s not applied is the groom binding because it’s tied to the original skeleton. So the reimport FBX has to be to the original skeleton.

Anyway I am going to update my post with your comments and suggestion for other users

Just go to the groom and rebind it to the new mesh, and then add the new bind in to the slot within the new mesh. Also you will need to do that with the eyebrows, eyelashes and peach fuzz.

Hi there,

First of all, apologize if this has been asked before but I can’t seem to find a similar thread to the specific question. If there’s a duplicate I will remove the post.

I am new to Unreal Engine and been experimenting with metahuman, especially customizing it beyond the website, through 3D software that I’m familiar with, Blender.

Last week I managed to export the FBX, fix the shape key, re-sculpt it, and import back to metahuman. Video here: HERE

I was so happy that I wanted to improve more of the face mesh to make it more like the model I want however, down the line I messed up and TL;DR, the project file is messed up, all the bones become missing and the mesh were all over the place.

Since then I have been trying to re-do it. Here’s what I have tried so far and where I have left off.

  1. Do the metahuman, download on quixel, import on unreal, export the FBX of face
  2. Convert the FBX with Autodesk FBX converter to fix the shape keys
  3. Import to Blender with shape keys, sculpt it, with minimal damage to the weight paint
  4. Export to FBX with some settings
    > Under Transform: X-Forwad, Z Up
    > Under Armature, Primary Bone X Axis, Secondary Bone, X Axis
    > Unchecked “Add Leaf Bones”
  5. Import to Unreal with some settings:

    Import Morph Targets
    Import Rotation, Z-90
    I follow the settings recommended by this guy here

  6. Swap the Face Mesh with the new mesh and Skeleton
  7. Retarget the Face_AnimBP to the new Skeleton
  8. And this is the final error. HERE

For some reason, the mesh turns upside down and looks weird, here’s it playing with the animation sample from AR kit
HERE

What have I done wrong?