Screenshots poorly rendered


I cannot get good result with screenshots, for an “dark” reason the AA and the screenspace reflection are poorly rendered when I use the screenshot fonction…
Is there any way to export good stills (at last with the quality of my working viewport)

Hello, Meian

To get a quality screen shot UE4 has a feature called High Resolution Screenshot. This allows the user to take screen shots at incredibly large resolutions if desired in order to capture the finite details in your levels.

In order to take a High Resolution Screenshot, go into your active perspective viewport and next to the perspective view option there is a small downward facing arrow to the left. Click on the drop-down box and and find “High Resolution Screenshot.” This will open up a prompt with various options for the screenshot.

High Resolution Screenshot Documentation: Taking Screenshots in Unreal Engine | Unreal Engine 5.1 Documentation

I hope this helps!

Thx for your reply :slight_smile:
This is exactly what I’m using already, please let me illustrate my problem :slight_smile:

notice the Hyper Low quality AA and dithered screenspace reflections…

No problem,

A couple of questions, what is your Engine Scalability Settings set to? To check this go to your settings in your active viewport and click on the dropdown box. Go to your “Engine Scalability Settings” and make sure they are on High and Epic settings to get a high quality image.

Also go into your project settings under Edit. Find the rendering section under Engine and under default Postprocessing Settings make sure you are using Temporal AA under the Anti-Aliasing Method.

Also a good way I like to take screenshots, I use the snipping tool which allows you to actively crop the area in which you would like to capture. The snipping tool is a device under accessories in your Windows Start menu. I hope one of these solves the issue you are having.

All my rendrering settings are set on “epic” and the AA method set is “temporal AA”
The way it’s happening is like “Temporal AA” doesn’t start when the screenshot is taken.
Another way to recreate the same problem is to desactivate “realtime” on viewport settings when I move a little the “Temporal AA” doesn’t activate (obviously) and generate the same artifact et dithering on reflections

What is your GFX card settings as far as AA methods are concerned? This could be an issue as well.

On my “nvidia control panel” it is set on application choices, so UE4 is free to set whatever it wants.
I just tested on UE 4.5 same issue…

It’s already my settings :slight_smile:

Ok no problem,

Do you have a global post process volume and/or any post process volume in your scene? If so make sure you go into Screen Space reflections and set the Intensity = 100; Quality = 100; and the Max Roughness = 0.8.

Make sure the bounds of the volume is around your scene and uncheck the unbound option. Let me know if this changes anything.

Ok cool,

A couple more suggestions. Have you tried taking the High Resolution Screenshot in a scale of 1?

Also check to see if the snipping tool I suggested dithers your reflections or distorts your image at all. If not this might be your work around for the time being.

There is no problems when I use screenshot with scale 1 neither with the snipping tool, the Temporal AA are not changed in these methods.

The “bug” happens only with scale superior than 1, while the screenshot function scale the viewport the AA doesn’t seem to update…

I will make a note of this, but as long as you are able to take a screenshot in some form without having your visual error issue that is what was needed. If you follow the documentation to the link I posted earlier they talk about taking a custom size resolution screen shot via console command.

Thank you,

Whatever it’s with the GUI or with the command (highresshot) soon as I request more than scale 1, I get thoses dithered reflection that poor AA quality… so for the time being there is no fix/solution about that ? Am I limited to scale 1 screenshot/stills ?

When you scale an image the pixels scale along with it which is why you are getting the lesser AA and distorted reflections. Also what is your screen resolution at currently?

I tought that the screenshot function would simply scale up the render output then capture it with updated screenspace reflections and Temporal AA :confused:
If it cannot, what is the purpose of this function :o

I’m running at 1920x1200

Use the console command with the HighResShot 3840x2160 and see if you still have the issue. If that does not have any change then there are some limitations of this feature as of now and we are working on improving it. Here is a link to others who are experiencing the same issue and maybe you can find a different solution as well.

I’m getting the same problem. High Res Screenshots come out looking like AA is turned off, and the SSR comes out horribly noisy, with random lines on it, too. And this is at x1.
Not at all what it looks like in the Viewport, and F9 screenshot looks accurate.

I’m using 4.5.1. I have all the settings suggested above, and I also have SSR at max quality (4)

Hey guys, I would like to ask if this issue has been fixed in 4.8? As well as if there are any workarounds for now?

Hey Gheromo,

Would you mind elaborating on the exact issue you are seeing with the High Resolution SS tool? We have made improvements to the saving of the screenshot as well as some other fixes. Have you tested the High Res SS in 4.8 preview yet?

Thank you,

Hey Andrew,

I did download 4.8 and gave a screenshot tool a go. Sadly it still produces screenshots without any AA applied. I guess it will be the same for cinematics and so on.