ScreenCapture2D bug in VR

Hi everyone!

I have a bug with a feature I am trying to implementfor my game and it’s the following :

I setup a SceneCapture2D that renders on a texture and that texture is transformed into a material that is applied to a plane. The problem is that on the resulting texture, there is always a black line that appears around pixels 1350 to 1400 in X and that is around 1000 pixels long in Y.

If my texture is smaller than this, I don’t see them, and if it gets larger, it stay at the same pixel offset in X from the left and the same height in Y.

After that I tried the same level but not in VR and the bug was gone. So it only happens in VR (I use the latest oculus headset).

Furthermore, I tried adding another SceneCapture2D, texture, material and plane to see if it would happen on that one too, but it did not! So after investigating only the SceneCapture2D with the highest priority will get that bar.

Highest priority SceneCapture2D on the left

Highest priority SceneCapture2D on the right

I looked around in the code of the component but found nothing worth of note.

Thanks a lot for your help!