Download

Screen tearing problem

hey, im noticing a lot of screen tearing on my game. was wondering if anyone know how to fix it or whats causing it?

Imgur

I have tried this too
Imgur

That’s not screen tearing. It looks like you’re moving the cube on tick.

1 Like

Yeah that is another problem i had. i had that and screen tearing. but that problem is solved it was motion blur, now i just have screen tearing left.

Here ocean, i got a pic of it
Imgur

That is a photo of your screen, correct? Assuming so, can you get a screen shot of it instead, or if that is too difficult, get a screen recording of it showing the problem? If you take a photo of it, then depending on your screen refresh rate and the shutter speed of your camera, you might accidentally be capturing more than 1 frame on your camera.

2 Likes

Like Doug says below, I’m afraid…

I think you need to do this after Set Vsync Enabled node. I would also set the frame rate limit to a high number like 240 so it doesn’t interfere.
image

1 Like

yes its a photo of the screen, i recorded with my phone then took a screenshot of the tearing in the video. i tried to take a screenshot of the problem ingame but then its not showing on the pic. but i can clearly see it irl. i will try to take a vid. have a 144hz monitor

and i get like weird effects below the character idk what that is about

They are almost invisible when i record or take pics ingame on my pc. but i can easily see them irl

already have it. Thanks tho

Yeah the cube looks fine here. I wonder if this is a ghosting artifact specific to your monitor. Do you see the same issue on any other games you play on that PC?

Do you mean the shadowy artifacts by the feet? I can see that one.

I’d try disabling some rendering features to narrow down the source of the problem. For example, in Console, run the following one at a time to see if they remove the artifacts. If not, experiment with other ShowFlags.

ShowFlag.MotionBlur 0
ShowFlag.AntiAliasing 0
ShowFlag.PostProcessing 0
ShowFlag.DynamicShadows 0

If that doesn’t help, you could capture a frame in RenderDoc and try to find out which draw call first draws the artifacts.

You can’t take a screenshot of screen tearing because it’s happening on the monitor, not the game. It is due to the game updating faster than the monitor’s refresh rate, which is why vsync limits the framerate to the monitor’s refresh rate.

If you have a 144hz monitor, why is your fps capped at 60? This makes me think you already have vsync enabled. If you type r.vsync in the console in-game, it will tell you if it’s on or not. If it is, the screen tearing may be because the game is out of sync the monitor.

1 Like

Yeah i played csgo the other day and i got screen tearing there too, but they were only noticeable when i was moving fast. turned on vsync and the tearing was gone. i get around 350 fps in that game.

yeah i mean the shadowy artifacts, I tried to run the commands but seems like they did not fix the issue. so i will try to disable other showflags. i used render doc and this is the ao, but im not a expert so idk if it is supposed to look like that Imgur: The magic of the Internet

noted :writing_hand:

yeah no i turn v sync off if i cap it at lower fps. i typed it in console too and it said 0. but if i cap the fps at 144 and turn on v sync then it will be synced right? also cant you just turn on v sync whenere you have the fps over ur monitor refresh rate.

VSync on, locks you to 60fps. VSync off, fps is unlimited depending on your card.

What you are calling screen tearing, Is what the above poster posted about your camera and it is catching the monitors refresh rate, it will show in a cameras picture. If that is not it, then it
is you having misadjusted settings. Get the settings right, that will go away.

You don’t need to cap your fps (if you mean t.maxFPS). Just enable vsync; it does the capping for you based on your monitor’s refresh rate (30hz, 60hz, 144hz, etc.).

That’s what adaptive vsync does. Your card should have it.

1 Like