Screen Percentage Unreal 5

Hi! I want to lower the resolution percentage in real time but I can’t find a way to do it in this version of Unreal, it doesn’t even work running r.screenpercentage in the console.

The option to do it in the post-processing volume does not appear either, as it can in U4.

Do you have any idea how to do it in this version?

Thanks in advance.


Hi mate,

I noticed the same issue with r.screenpercentage in Unreal 5 as well. I know it’s not an ideal solution for super sampling, but used to be quite useful for recording high res videos. I can set it up via the viewport in the editor, but the console command doesn’t work for me as well (works in UE5 preview build and UE4 builds, though) - plus it’s not showing up as an option/feature in the PP volume.

Thanks for any help there!

I faced the same issue when compiling the preview builds prior to their official release a few months back, and thought it was just a bug. I figured that maybe they had not yet fully restored all original features back into the engine at that time.

Then official 5.0 build came and someone told me that Screen Percentage may have been removed in favor of the new Temporal Super Resolution. I didn’t see where this made any sense and felt like its just another situation like what happened with Tessellation, where one thing cannot substitute another.

But anyway, you guys can do what I did to get around this and just download a free app that batch converts multiple images to a set resolution. The process is essentially the same as doing it with screen percentage except you are involved in the final step, which of course using an external application to do the downscaling.

In case anyone has the same problem, what seems to be the happening is that the editor’s screen percentage overrides the project’s screen percentage. To disable that behavior, you need to configure the following settings: [file > editor preferences > general > performance > viewport resolution]. The main setting you are looking for is ‘override game screen percentage settings with editor settings in PIE’ (disable it).