Screen Fade and Bloom Settings

To make it simple, if Bloom is disabled in Project Settings → Rendering → Default Postprocessing Settings, Matinee Camera Fade nor Start / Manual Screen Fade nodes work.

Tested in my project as well as a default Third Person Template project (Maximum Quality Settings)

Kind of important to fix since fade in / fade outs are important to VR transitions, and Bloom needs disabled.

Hello SaviorNT,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints that may be involved with this issue?

Yes. I first noticed in my project, and then launched a new project based on the Third Person Template.

Detailed Steps:

  1. New Project, Desktop | Scalable 3D
    or 2D | With Starter Content
  2. Create new matinee, new director track, new fade track
  3. Add keys (Time 0, Value 1), (Time 2.5, Value: 1), (Time: 7.5, Value: 0)
  4. Set matinee to play on level load
  5. Test Level - The matinee camera fade will fade as normal
  6. Edit → Project Settings → Rendering → Disable Bloom
  7. Test - The matinee will play, but there will be no camera fade

No blueprints involved unless you want to use a Start/Stop/Manual Camera fade instead of a matinee sequence. Both matinee sequence and blueprint based camera fades fail to fade the camera in/out

The only reason this could happen is if the camera fade was classified as a Bloom style of post process.

Hello SaviorNT,

I tried to reproduce this issue in several projects with different settings. I was unable to do so with the information provided. Is it possible that you made any other changes to the project and/or settings?

That is super odd. I can upload the test project. As I typed the reproduction steps, I performed those steps in just that order starting with a new project.

Hello SaviorNT,

After testing the project that was provided. I believe that this is a known issue (UE-29895) and that issue has been submitted to the developers for further consideration. I will provide updates with any pertinent information as it becomes available.

Note: I found that setting your engine scalability settings above medium for your post processing helped with this issue on our end.

Make it a great day

Thanks! At least we now know that I am in fact, not going insane :slight_smile: