SceneDepth Blendable ignores translucent objects

Hi All,

I’m trying to render a depth pass for my matinee image sequence export for further post-processing in a compositing app. I set up a Post Process domain material and applied it as a blendable, then attached the SceneTexture:SceneDepth node to the output. This works pretty well for rendering a depth map.

However any object with a translucent material does not show up in the depth map at all. That means things like leaves which use image maps as cutouts disappear entirely. So in the end it is not usable. Is there something obvious that I am missing here that would make this work?

I’ve already tried all the Blendable Location options.

Hi jstarrdewar -

Translucent Objects are treated in a different pass of the rendering thread than the Opaque Objects. If you are only rendering out the Depth Pass for a separate application I would recommend temporarily making the objects opaque for your depth pass then revert for other passes. Alternatively you can place the Translucent Object in a Blueprint, duplicate the object and assign an opaque material to it and in the rendering options of the mesh’s details panel uncheck Render in Main Pass and Check Render in Custom Depth. By doing this the opaque object will not be rendered in the final scene but will be rendered in Depth Passes.

The one limitation is you will never get a Depth Rendering through a Translucent Object, but in most cases this is unimportant to depth maps.

Thank You -

Eric Ketchum

Hi Eric,
I can render an object into Custom Depth, and that object will not appear in the final scene. But I can not access Custom Depth when shading an opaque object. Is it possible to pre-render sth (just) into depth buffer and access that buffer in main rendering pass?
I am in this trouble for a long time. Thanks a lot.

Are you Ash Ketchum’s brother?