SceneCaptureCube not showing custom PostProcess effect

I have a custom post process material to output depth as colour, that replaces the tonemapper. I attach the material as a blendable in the global (unbound) post process volume. In the editor I can see the effect being applied, so that’s good.

SceneCaptureCube actors seem to ignore the effects, and they don’t seem to have a setting to allow any custom effects/blendables. They have lots of checkboxes for the post-process pipeline, but that results in just altering the color output.

How can I make the SceneCaptureCube to work as intended?
Even more advanced question… How can I have two scene capture cubes at the same time, using different post-process materials?


Ok, found my solution, I hope it helps others…
(If my solution produces bad sideffects, I’ll update here)

I went to the source code, and I duplicated the functionality of SceneCaptureComponent2D with regards to PostProcessSettings, PostProcessBlendWeight and CaptureSource: I added the member variables in SceneCaptureComponentCube, added the Serialize() override and made the appropriate changes to

void FScene::UpdateSceneCaptureContents(USceneCaptureComponentCube* CaptureComponent)

to use all 3 variables, in the same way they are used in

void FScene::UpdateSceneCaptureContents(USceneCaptureComponent2D* CaptureComponent)

Using MSVS 2015 I got an internal error near the enqueue command, so I just added duplicated pretty much the whole function, checking the value of bUseSceneColorTexture and setting it as a static const bool in the bodies of the if/else blocks.

Hey BabisK,

Thanks for the information above, I’ve made all the changes in a plugin version of the USceneCaptureComponentCube. Before I make the engine change to FScene and build a custom version of the engine I’m interested to see how you got on. Did it work for you?