SceneCaptureCube Animation hitches

Whenever I update a SceneCaptureCube in my map (by moving it and forcing an update every second), there is a visible hitch in the animation of the skeletal mesh in the scene. It’s as if it is updated incorrectly on the frame the SceneCaptureCube is being rendered. I think this issue started when the project was updated to 4.9, there were no hitches in the animation before. This is only seen on skeletal meshes, everything else seems fine.

I just tested it in 4.10.2, and the problem is still there.

edit: Looking into it further, it appears the reflections on the skeletal mesh are “popping” when the sceneCaptureCube updates.

Yes, I’ll try to set up a simple scene to demonstrate. However, this was working before. I’m not updating it each frame, I’m updating it every half second, saving it to alternating files, then interpolating between the two, and then using it in a water material. I removed the skylight from the scene because I didn’t like how it appeared in reflections, would this cause the issue? Should I use the cube maps in a Set Cubemap Blend node for the skylight?

Hey 3DMoss,

Could you provide me with a simple test project or steps to reproduce this issue on my end. I will say, the hitch is pretty much expected as well as the popping since you are calling the entire scene to update each frame which can become expensive.

The popping you are seeing is probably due to your ‘Skylight’ which is not getting called to ‘Recapture’ the reflections.

Let me know if you have further questions.


Hey 3DMoss,

I would definitely look into using the Set Cubemap Blend node, as it handles the transition between specific cubemaps set within the skylight pretty well. You are still going to need to run the ‘Recapture’ option on the skylight which we make the users responsible for properly handling so it does not hitch.


This bug appears to be fixed in 4.11 preview 5.