Scene under HTC VIVE - vision unclear / pixel looks huge.

Hi all,

Have anyone experience this before? We have developed opening Scene using UE4 under 4K. Everything looks great and smooth on computer, but when play on VIVE,
it looks unclear (adjust the vision diameter, until not help) and pixel looks huge… it makes every tester so dizzy.

Anyway to make performance better / smooth / clear??? and somehow I need to justify the setting from UE4?
Computer setting:
1080 Nvidia
16G ram.

Need help please.

You can add an “Execute Console Command” node in your Level Blueprint with the value “r.ScreenPercentage x”. By default, the x value is 100 (depending on your engine scalability setting). Don’t hesitate to set it to 150 or more if your scene allows it.

The default antialiasing (TXAA) also tend to blur visuals a bit in VR. You can either set it to FXAA or switch to Forward Rendering and try out MSAA (needs a bit of work to adapt the lighting and materials of your project).

You wanna do 4K in VR? GLHF…

Some idea of the complexity of the scene would help (screenshots / video etc). Super-Sampling using Screen Percentage may help, but you’ll pay for it in performance.

Thx Legendre, I will test it out again.

No problem, keep us informed.

Hi Legendre,

“Execute console command” added to 280, everything so clear and smooth, but depends which Scene to run, cause it affect the overall performance.
Some Scenes so smooth, but some are choppy.
FXAA / MSAA also tested, screen completely flurry so I turned it back to default.

Is “Execute Console Command” relies on Hardware Performance?
What else I can tune up this scenario?
Any idea?

It isn’t the “Execute Console Command” node that relies on Hardware Performance, its the “r.ScreenPercentage x” parameter.

Unfortunately, as @TheJamsh said, optimization is key. If you want to render your scene in VR AND at high resolution, you’ll need to optimize your scene a lot.

A few hints :

  • Simplify your materials and instantiate them
  • Avoid using complex post processing
  • Translucent materials are performance killers
  • Try to limit drawcalls
  • The higher the target render resolution, the higher the performance needed.

And you can profile your scenes with the performance profiler.

Thx LegendreVR,

We have optimized almost everything, Screen definitely great and smooth but only run under “Two 1080 SLI” and I7 6700K OC, single video card not able to run it at all.