Download

Scene too lighter after building lights and volumetric fog pixelated

Hi I have this problem with the building of lights in my scene. Until yesterday everything was working fine, but today when I opened the project the scene looked so bright. I have checked so many things, trying to delete building and redo it, launch the building with no lights, set the environment lighting to something very low but the result is always the same. No errors when build is done, just some warnings of overlapping UVs. Do you know why it happened suddenly this terrible issue?
And I’m having also a problem with my volumetric fog, it looks very pixelated, is there anyway to increase the quality without using the console editor? I’m working on this scene just for cinematic purposes, so it will not be playable.
Hope you can help me.

This is the scene without lightmaps:

https://i.ibb.co/Q66W3tM/Screen-Shot00000.png

And this is the result after the build:

https://i.ibb.co/W6R7DDR/Screen-Shot00001.png

If there’s a warning of overlapping UVs, then it’s likely that needs to be checked in the material UVs of the scene. However, try not starting there, as there’s lots of materials and I somehow think it is not all the materials that have overlapping UVs…which is how the scene would become so bright all over, I hypothesize. Instead, try these:

  1. Check if there’s an Unbound Post Process Volume in the scene. Look for it in the World Outliner, select, and look at the Auto Exposure settings, and other lighting settings for something that is identifiably related to the problem (such as a high intensity of global illumination). Try also to disable the post process’s “Unbound” setting, so it’s not blending with the entire world / scene.
  2. Check Lightmass Importance Volume location and scale. If it’s smaller than the room in the photos, then it could be causing a problem.
  3. Check Lightmass settings in World Settings. Post a screenshot of those.
  4. Is there a skylight, and what is its mobility? Is there a directional light and what is its mobility? what are the settings of either (if only one or the other is in the scene) or both?
  5. How were UV lightmaps made for the materials and meshes in the scene? generated in Unreal, or in an external program?

Found the problem! Seems that in my directional light my Cast Static Shadows was turned off, now with that checked it works, thank you for your help it will be helpful also for the next problems I will have :slight_smile: About the Volumetric fog pixelated the only way to visualize it better is to set the Engine Scalability Shadow to Cinematic?

Engine scalability sets specific console variabes for the grid size of volumetric fog. Change the scability and let it set the variables for you, set them yourself when you’re in the editor, or set them in the .ini file so they’re always active by default when you load the project.

Why isn’t the grid size console variable simply a setting in the fog’s details panel? This engine must intend to introduce console modification of a program. Or perhaps, in the settings somewhere. Lots of the stuff would be easier to tweak / adjust in the details panel, or a sub-panel of settings.

Yes I’m agree with presto423, It would be a great feature cause it’s not so “user-friendly” or immediate but thank you for the explanation rosegoldslugs!