Download

Scene still lit, even though all the lights are off

I’m working on this scene for like 2 days now, everything seems to be work how I wanted it to, but when I’ve gotten to the stage where I wanted to add lights that will switch on and off I’ve discovered a problem, even though all the lights are off, the scene still looks like something still illuminates it. Why does that happen?, I’ve tried to build the lighting again but there was no difference. I need the scene to look dark the way it looks in real life.

Here is how it looks like:

With lights

d3497dbe9900fa49b787207eb8a59479398e4d2e.jpeg

No lights

8cdad9e8cf2c2971ff853380ccbc0acdbd163b90.jpeg

In Lightmass, there is an environment color that can add equal ambient light of any color to everything at once. Go to World Settings > Lightmass Settings> Environment Color and set it to black.

Also, I’ve never set any lights to be not “visible” like I see in your screenshot. The “right” way to toggle a light on and off for testing is the “Affects World” checkbox. Maybe you did that too.