Scene Color property in PP Volume don't Override the Camera on

I don’t know if is a limitation but I haven’t found something about it here around in the answehub and google in general.

I have tried before a PP Volume to override the default PP in the camera, but today I’ve tried for first time to play with the scene color and no effect.

Somebody had same experience?

Hello ,

I would like to get a little more information from you in order to better assess this issue.

1.) When you create the volume do you have it set to unbound? This should flood the entire project so you don’t have to be inside the volume itself?

2.) If you are not using unbound are you entering the volume?

3.) It could be that your camera PP and your PP Volume are fighting for which should be called first. Can you turn off anything you turned on in your Camera PP and still not see scene color with the volume?

4.) Does this happen in a clean fresh project? Can you create a blank project and add the camera and volume and still see this?

After I have this information I can begin to narrow down what could be causing this.

Hello ,

I haven’t heard from you yet. I was wondering if you had a chance to see the above post?

Sorry for the delay, I can’t connect daily for job and family reasons…

And not, it doesn’t work, try by yourself, activate the scene color in character camera and put a PP Volume with active another scene color. In design time shows properly, but at play turns to camera color scene.

If in the PP Camera scene color is not activated the volume one works, but no override it if is activated.

Hey ,

That’s ok, I was just checking to see if this was still an active issue for you.

What you are seeing is expected behavior. What happens when you set a post processing volume and a camera with post processing enabled is a calling stack.

So, by default your volume is set to a priority of 0. While the post process is called last when rendering as a deferred render pass if you add a camera you add that camera to the end of the rendering list. If you go to the Camera Settings on your camera you will see a tab for Post Process Blend Settings. By default that is set to 1. Think of this is dimmer switch. At 1 this is completely enabled and take priority over all over rendering. At 0 it’s priority moves down the list and is essentially off.

Cameras do not have a true priority setting but it can be turned down. So if you wanted the scene color set in your volume and you don’t want the scene color to take priority in your camera you can switch the blend weight from 1.0 in the camera to 0.

Going back to the “and not, it doesn’t work, try by yourself,” typically we ask users to test this for themselves because we want to see if this can be reproduced in an other project and see if it is computer/project specific. This is done so if we do want to further test with a specific project we know which one and we aren’t going back and forward with users for a week.

This is a picture of a camera with a blend weight of 1 and a post process, set to unbound, with a blue scene color.

This is the result with blend weight set to 0.

Now, as I don’t know what you have intended for your project, I do not know if this is the solution you were looking for as the blend weight will effect all of the settings on your camera.

Let me know if this is a valid solution or if you require further assistance.

Sorry for the delay again and thanks you for your time, of course deactivating the PP in the camera (blend weigth = 0) deactivate the Camera PP, but is not a solution for me because I’ve in the camera another parameters activated like auto exposure for whole levels for bright reasons.
At the moment can solved without PP effects in the camera and placing more PP Volumes around the scene to play with the priority or activating and placing the same needed parameters of the camera in the PP Volume one, but the strange the override over the camera PP working before with another parameters, I supposed PP Volumes overrides always the camera. Just the Scene Color not respect it till date.

Yeah, I believe adding more pp volumes and assigning priorities at this point would be the way to go. I can enter a bug for this but I can’t guarantee that this is not expected behavior. I think the camera, by design, is meant to render last. This is because of it’s ties with Matinee and creating films.

If you want me to enter a bug I can and I can attempt find out some more information on this issue.

Never mind, is not a important issue and like speaked could be remedy by other ways.
Thank you very much.