Download

Scene capture doesn't render post process

Hi, as the title says, my scene capture component render the scene without post process. I read on old posts that the trick is to change “capture source” to " final color (LDR with post process)" but I can’t find this option in the drop list. The only “final color” that I see is “final color (LDR) in RGB”, but it doesn’t capture anything, so what’s the solution please? As i’m working on a cel shading game, I just can’t use post process in scene capture and I need scene capture to get an item preview in the game menu.

Sorry for bump but I really need help with this

The option “Final Color (LDR) in RGB” does post processing. Not sure why you don’t get anything. Maybe check your render target format.

Thanks for your help.
I tryied to use “Final Color (LDR) in RGB” with some tweak and now have this result (image 1)

But as I don’t want a black background behind the objects, I’m using the alpha channel to mask it in my UMG material. (image 2)

The problem is, as you can see, the alpha channel doesn’t only mask the background but makes the object translucent too. (image 3)

Do you know how I can mask only the background?

Nobody knows?

I can’t believe that nobody use scene capture with post process AND transparent background

Did you ever figure out how to get this working? Final Color, Post Process, WITH transparent background.

  1. Prepare the SceneCaptureA set to “FinalColor” and the SceneCaptureB set to “SceneColor (HDR) in RGB, Inv Opacity in A”
  2. Set two SceneCaptures to equal Transform, FOV
  3. In the material, set the result of SceneCaptureA in Color and the result of SceneCaptureB in Opacity
    There is a way called.

Thanks Masui, This solved my problem!
but I’m just worried that this isn’t going to be a performance problem.
Don’t Render Tags require high performance?

Please, more help from people that got this working :::
:
With ::

  • Shading Model: Default Lit,
  • Blend Mode: Translucent.

Errors in channel types connections (Coercion) ::

Add a mask component after your “texture coordinates” node

Thanks !
:
:
​​​​​​​It looks like now I am having a similar problem that Haoris did early on :
:

:
SceneColor captures, but FinalColor is just black.
:
:
Thoughts on where I can start investigating next ?

Hi, if you doens’t see you post process being captured even if you set ‘final color’ then try to check ‘capture every frame’ and ‘capture on movement’. When i was capturing manually i couldn’t see post process, it showed hovewer when checking those flags

Hi. I had this problem too, and in my case I found a solution.

  1. Set your Scene Capture to “Final Color (LDR) in RGB”
  2. Make sure you have “Post Processing” enabled in your Scene Capture
  3. The most important part. Make sure tha your scene capture that is placed in your level also has those options enabled. In my case Scene Capture that is placed in my level was not updating with its parent blueprint. I had to remove it, and place a new instance for it to work.

I get this problem too. On my side that because I use Capture Scene with a Tick. I fixed by checking Always persist Rendering State