Download

Scene capture component dont generate mipmaps?

Hi guys :slight_smile:

If i switch texture sampler with scene capture target texture to specific MipLevel, nothing actually changes.
Render target just doesnt generate mipmaps?

it’s a missing feature :rolleyes:

Is this still missing?

There is a Auto Generate MipMaps in the RenderTarget Texture Asset but when set on it just fades to black because its missing the mipmaps.

Auto Generate Mips flag does not trigger mip generation after drawing to render target from blueprint or scene capturing into it. You would need a plugin to do that currently. Besides, automatic mip generation, that flag refers to, is not available on all platforms.

It would be cool to have RHI-agnostic universal mip generation function in UE4, exposed to blueprints, but for the time being, you’d have to use code for that.

You talk about some specific plugin?