Scene capture 2D texture is too dark

So un using the spectator Mode for VR, using the texture to screen Mode. The texture im using is the render target of a scene capture 2d component. The texture is extremely dark, and I cant seem to make It brighter

I have increased the ‘Indirect Lightning Intensity’ to around 12 under the ‘Global Illumination’ settings in the capturecomponent2d detail panel. Don’t know if this ok but solved this kind of problem for me…

I don’t think it works well…

The culprit is Eye Adaptation aka Auto Exposure in post processing.

Scene capture component resets post processing computation on each frame, because of that Auto Exposure adaptation is not progressing at all and it’s permanently locked in minimum brightness value. Note that scene capture even if you do that from same position can’t just grab ready pixels from the screen, since this feature is primerly made to capture scene from other location, so it needs to render the scene from 0… and it litterly start from 0 on every frame and this is where issue sits

Best solution i know so far is simply setting Auto Exposure → Min Brightness to higher value… effectively this variable becomes brightness of captured scene. But this solution won’t fix the issue on every application, aspecially if you relay on 1:1 pixel accuracy, but if you just need to get shot from one location to use it in menu or some monitor in the world, setting this is scene capture component post processing settings should do the job. Either way eye adaptation won’t work on captured scene whatever you do because of this.

I trying to find solution for this myself as for what i’m working i can’t just change brightness of the captured scene, if any know better solution i would be very thankful. I know some other solution i find suggests changing target gamma of texture target, but if you ask me changing eye adaptation settings gives better accuracy. Setting gamma won’t give you 1:1 accuracy either way, setting eye adaptation min brightness at least let you set brightness to be fixed to something more accurate to specific eye adaptation value.

If it helps, we had to set our Post Process Material’s Blendable Location to “Before Tonemapping” to fix the “darker color” issue.

I don’t think it is the Eye Adaptation because I turned it off and it is still too dark. Also Eye adaptation does work for UE4 4.22 for scene capture components, and does change in brightness each frame, but it is still too dark nonetheless. I think it is something else.

Hello, for those still looking for a solution to this problem : just increase the “Target Gamma” under texture render target in your render target 2D

4 Likes

You posted this yesterday, and I needed this answer today - you are ultra clutch.

Throwing in my experience and solution as the above did not solve the issue for me. I had to set the Render Target Format (in the Render Target) to RTF RGBA8 SRGB (I was using RTF RGBA8). Tested on Windows and Android (Quest 2)

1 Like

The underlying issue was fixed in 5.3 and we also updated the VR Spectator Camera in the VR Template which already had the hacky fix w. the gamma increased.

1 Like

In 5.2 set : scene capture component (cube) — capture source — final color (ldr) in RGB. then play with gamma !