Scene capture 2d not hiding meshes

Having an issue with a Scene Capture 2D I have setup not hiding skeletal meshes. Trying to create a minimap that, instead of showing the players it will show dots on the map. I hid both skeletal and static meshes just to see if it would work, but it looks like it’s not! I am using spawn actor to create the minimap, so it should be picking up on the defaults as far as I can tell. Is there another setting I need to configure to hide the meshes? Trying to optimize as best as possible since I know they can be a little heavy on performance.

Moved to C++ class and it works. Not sure these flags work in BP.