Download

Scaling sprites without interpolating?

Hi, I’m having an issue placing and scaling pixel art object in my scene: every texture i put get interpolated into a “soft” one, while i want to preserve hard edges (like in photoshop).

This is one texture example:

ee9f88b26b3e00f1be0b5a0f06b031f7ec0d94d5.png

This is what i get in the UE

00d72d2a2e0680c48326051de158e5a5d462bda2.png

All texture are in 256x256 canvas.

What can I do?

There are not enough pixels, Also choose nomipmaps and see what happens.

Set Texture Filter Nearest.

I tryed the No MipMap but nothing changed. Where can I change the texture filter? I can’t find it.

FOUND!

Now works fine! Thank you :slight_smile:

http://s28.postimg.org/bhet724sb/Cattura.png

Try to click these buttons, it would give you more options.