Download

Scaling clipping issues

According to https://docs.unrealengine.com/latest/INT/Platforms/VR/ContentSetup/index.html#vrworldscale You should change the “world to meters” value if you want to change the scale for VR. It even suggests using a value of 10 for making things seem large. This works well except that the near clipping makes it impossible to see anything held in your hand when scaled this small. Apparently the clipping is not scaled with the world scale.

I have tried using the changing the near field under project settings/general settings and also using the “set clipping planes” BP node and while they helped a bit but they seem to have a minimum which is too large when you have scaled down.

The only way around this so far is to scale everything larger than life and scale the player up when normal size. This is not ideal.

Does anyone have suggestions?

I’m using Vive but I would assume this affects all headsets as it is a camera issue.