Sampler Requires non-VirtualTexture


I started a new project (several, actually) with Virtual Textures enabled (for nothing more than blending assets with the landscape.) On one project, I turned off converting textures to virtual textures on import, and left it on in the other project. Yet, no matter which project I am using, adding a Quixel asset via the bridge imports the high-res nanite geometry, and a very blurry (unusable) texture. If I inspect any of the Material Instances, I see the error “Sampler Requires non-VirtualTexture” for every texture bridge imported, and all are indeed virtual textures regardless if that was off in the settings or not. Never had this issue before, but now it is constant, and I have been using virtual textures in the past for blending. I can convert the textures back manually… but I can’t even find the error mentioned at all.


Update: Problem seems to have been fixed after a clean engine install (as clean projects still had issues. Now no clean projects have this issue. Deleted all my old projects, so can’t advise on whether it fixes it for those.)

1 Like

I have the same problem and I dont know how to fix it. I need help with this. All the textures of the surfaces imported from bridge are virtual textures and the software say me than albedo and anothers has an error because it need to use non virual textures.

Same here. But in my case it was clean UE5, none of the virtual texture setting where touched, so clean default UE. And after Bridge asked for an update I ran into this issue. Turning off Virtual Textures in the project settings helps, but the performance drops significantly as I already assembled a pretty massive project. My guess is it’s most likely failed megascans’ default shader.


It sounds like a mismatch where the Quixel master material (the sample parameters) is setup for non-virtual textures, while the texture being set in the material instance isn’t.

If it says “Sampler Requires non-VirtualTexture”, you need to open the texture and turn off “Virtual Texture Streaming”. (Virtual textures will say VT.) The Quixel master material is setup for one or the other.

In Project Settings, when you enable VT, there’s an option to automatically import textures as virtual which is on by default. So new Quixel textures come in virtual while the master material is set as non-virtual. It’ll look blurry and you’ll have errors in the material instance. You’ll want to turn this option off. (However, Quixel seems to ignore it.)


This is genius, and solved my problem. I had a Quixel material I added to the project early on, then later enabled virtual textures. I recently started experiencing lots of crashes whenever the shaders compiled… and lo and behold, this was the cause. UE didn’t like that I accidentally mixed virtual and non-virtual textures.

Ultimately, I had to edit the master material, convert the default textures to virtual textures, and then change the samples to Virtual …

Bam, textures work and no more crashes. Thank you!

Use this documentation and replace the Megascans Materials default textures with any with virtual textures enabled.

1 Like

I was having the texture marked with VT and was unable to change it with any other textures for the megascan asset. I’m using sequences for video render in UE5 with a heavy scene setup for cinematic render. I just right-clicked on the Albedo in the content browser and choose “Convert to Regular Texture” then it loads the high resolution of the texture without any blurry effect.

I’m using CC3 Character and that solve my problem. Thanks for sharing it!

thanks work fine now

I tried this but it ruined all my materials, so I recommend that if anyone tries this, do it with only one material and texture first to make sure it works for you.

Astaraa is exactly right. I’ve tried this with a new project using strata materials.

Very obnoxious issue. Bulk asset editing is my only real solution thus far.

As of Feb 2023 to accomplish this:
How to Convert VT into Regular Texture: For Megascan textures accidentally downloaded as VTs, but you want a regular texture. RC on Texture and in the Texture Actions list, choose: Convert to Regular Material. When you hover your cursor on this option it says : Converts this texture to regular 2D texture if it is a Virtual Texture.