Download

RVT runtime virtual texture of landscape not working [solved, MacOS issue]

Hi, for RVT runtime virtual texture on landscape in the setup with VirtualTextureFeatureSwitch it just uses the regular material, and if set it to RVT only it is just black. Followed the documentation and the livestream, what could be missing? 4.24.

First things to check are that the landscape actor itself, the RVT Sample node in your material and the RVT volume are all pointing to the desired RVT. Are those connected afayct?

Yes, i set it up new so there is no other it could point to

Let’s make this simple. It should work to render magenta color, no ?

for your material, I would think so. I’ve had instances where a black landscape was “fixed” by rebuilding/resampling it on the landscape tab. I have also tried simply adjusting the RVT volume manually (just nudge it up 1 integer or something silly) and had it apparently refresh and display correctly. I know those are stupid hand-wavy ideas but i was just trying things on the demo scene. Sorry I can’t be more help.

Thanks POTWD

I had the same issue but the root cause was that I was trying that on a flat landscape, when I sculpted that a little and copied bounds again it worked

I’m having the same issue I think. I posted here RuntimeVirtualTextureVolume and RuntimeVirtualTexture Giving only a blank black texture - UE4 AnswerHub

Did you ever find anything wrong or causing it?

Sort of, the issue at the time was apparently the MacOS engine version, i tried it on Windows and its absolutely fine.

it work but i think its not production realy - bc off alot off crashes - and it dont support displacment yet

IF you make some changes on your material, a static bool parameter to enable or disable virtual texture, and make 2 different material instance put the normal material on landscape, and add the second material instance with RVT enabled and tesselation disabled in material property on LOD 1 of landscape you will have Displacement and RVT without crash! i will do a video about it soon my youtube channel is LucianoJacomeli you will find some news there soon

Hi, could you fix the problem? if yes, can let me know what you did!

Hi, as stated above it was an issue with the MacOS version of UE4 (either general or just my specs). In windows it worked on the same version no problem. I have not tried again on Mac since.