RunUAT.bat ERROR: AutomationTool was unable to run successfully

hi ,

i did package my game succesfully for android but if i can build mygame to ios for development ,
everytime “RunUAT.bat ERROR: AutomationTool was unable to run successfully.” errors give to me.
(win 8.1 and UE version 4.4.2link text
please ,what is wrong ?

i attached log file,

Howdy serhatuzuner,

Thank you for reporting your issue. I just need a bit more information from you before I dive into this issue. Would you be able to share you DXdiag and your project log files on this post?

If you load up a brand new project and attempt to package for iOS, do you still see the same errors as your personal project? Any additional information would be greatly appreciated.

Thanks and have a great day!

hi dear sean,
attached myerrorlog.txt file is my game log file.and now,
and,i did make a new Project from UE 4.4.2 topdown blueprint game.and i did attach this Project error log file.

thanks.serhatlink text

dear sean still waiting your helps :slight_smile:
i did upload my first little game fundino Google play store but still waiting for ios :slight_smile:


Hey serhatuzuner,

Sorry about a lack of response. Would you be using a binary or source version of UE4? Have you attempted to package on 4.4.3 since it has been released?


hi sean,
i’m using binary version ,blueprint Project (a tappy chicken based game) ,and i dd try package 4.4.3 but didn’t package.
i attached outputlog file for you for my text.


I’m using 4.4.3 and getting the exact same issue. Hopefully you guys can fix it.

Hey serhatuzuner and TSpartanT,

It looks as though you may not have permission to write to C:\Program Files\Unreal Engine\4.4\Engine\Intermediate\UAT\IOS\ue4commandline.txt

You may not have permission to write to that directory, or there may be a ue4commandline.txt which is read-only

hi dear sean ,
allthings make engine for package,i didn’t change
“ue4commandline.txt” or other file :slight_smile:

what must i do for this ?


Just put your project in your documents instead of your Program Files

That’ll fix the error :slight_smile:

hi TspartanT,
i made this but still same error :slight_smile:
because of,i attached ue4commandline.txt and uat.log in 4.4/intermediate files

link text

Dear sean , can you see last files for my errors

Have you switch versions of UE4 to 4.3? Looking at the log files, it seems like 4.3 is missing multiple .dll files. Have you tried to build this project in 4.4.3?


Dear sean this log files 4.4.3 build log files.

Hey serhatuzuner,

Would you be trying to launch the project from Windows Explorer or from the UE4 launcher?

This may be from the reason why it is showing in the log files that the project is running in 4.3 instead of 4.4.3. You would need to open a copy of the project in the 4.4.3 version of UE4.


dear sean,
everytime UE4 launcher.i did copy to 4.4.3 but same error.

after,i installed UE 4.5.0 and make a new fps Project and make all properties after i packaged for ios .but still same error.
i attached log file 4.5.0

dear sean why didn’t i package any Project?

thankslink text

Would you happen to have this directory: c:\program files\unreal engine\4.5\engine\intermediate\uat\ios ?

If you do not, create that directory and see if that fixes the problem that you have been seeing.

dear sean ,yes i have this directory ?

i update 4.5.0 after did package this Project but engine gave same error.
sorry :frowning:

Hey serhatuzuner,

Would you be able to uninstall and then re-install UE4 on your PC? This has been able to fix the error for other users packaging for mobile.

Hi serhatuzuner,

Just wanted to check in with you and see if you had any luck with uninstalling of the Engine. Please let me know when you get the chance so that I may look further into this issue if it is still occurring.

Thanks and have a great day!