Runtime D3D Crash of Ue5-ValleyOfTheAncients


Fatal error: [File:D:/build/++UE5/Sync/Engine/Source/Runtime/D3D12RHI/Private/D3D12Util.cpp] [Line: 648] pResource->Map(Subresource, pReadRange, reinterpret_cast<void**>(&pData)) failed at D:\build++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12RHIPrivate.h:1286 with error DXGI_ERROR_DEVICE_REMOVED with Reason: DXGI_ERROR_DEVICE_HUNG


Currently I can run the demo for around 5-20 seconds before I get a direct X crash. It looks great before it crashes. I’m currently on the latest stable Nvidia 470.14 Game Ready drivers.

Specifications are AMD Ryzen 9 3950x, Gigabyte Eagle Nvidia 3060ti and Seagate Baracuda pcie4 Ssd. I don’t get these crashes on any other direct X application. Was hoping there is a known fix for this as it seems others have have the same issue.


Do you, by any chance, have tools like Incredibuild installed in your system? I have experienced D3D Device crashes with past versions of the engine.

1 Like

I have the same issue with my AMD 5950x, ROG 3090 o24g, Nvidia 470.14. I also tried latest driver from Geforce Experience (466.47), but it’s the same. I suspect it’s because My Windows 10 is on Developer Channel, which is not the stable version.

I am also having this issue. I have a Ryzen 9 3900x, RTX 2080ti, and 64GB of ram. I may have Incredibuild installed. I’m on Nvidia driver version 466.47.

I am about to move to windows insider preview 21390.1 as this is my development machine, it’s likely its due to the insider build I was on, but I haven’t been able to move for about 2 months now due to dev stream being so unstable and work requirements. I’ll update this post later if it seems to be behaving. So I use hardware accelerated gpu scheduling, but I would hope that’s not the issue. I can get the demo to sometimes behave but sometimes it just d3d hangs after pushing the gpu too hard (around 95%).

EDIT: Insider build hasn’t changed the issue. So the crashes coincide with an event “Display driver nvlddmkm stopped responding and has successfully recovered.”, which doesn’t look great ngl. I don’t have these crashes with any other application, so I have no idea what’s causing it, but I presume it’s either driver misbehaving with ue5, or a bug in ue5.

1 Like

Same here when trying to render a scene. I7 RTX 2060

I have installed Access 2 Hotfix. Although it says the crash issue is fixed, it crashed again on my machine(ROG 3090, Nvidia 470.76 Driver).

LogInit: OS: Windows 10 (Release 2009) (), CPU: AMD Ryzen 9 3950X 16-Core Processor , GPU: NVIDIA GeForce RTX 2070 SUPER
LogInit: Compiled (64-bit): Aug 26 2021 11:42:44
LogInit: Compiled with Visual C++: 19.29.30038.01
LogInit: Build Configuration: Shipping
LogInit: Branch Name: ++UE5+Release-5.0-EarlyAccess

me too

This issue also happens randomly while working with editor too (ue5-main included).

I’ve 3080ti.

same here. It crashes randomly in the dark world bit (not the first part). I have 3060ti with 16GB RAM on both game ready and studio drivers (latest)

ok turned out in my case the problem was Windows 11. once downgraded the OS everything started to work as it should.

I have this issue on Windows 11 only. Viewport is fine, but crashes when playing. Always in one of two spots: when the character stands up, or within about 5 seconds of entering the Dark World.

Windows 10 is fine with the same drivers as below.

RTX 3090 (GameReady 496.13 or Studio 472.12)

exactly the same problem i have in windows 11 with 3070
any fixes ?
this is a nvidia driver issue or ue5 ?

I’ve replicated the error with the Megascans Goddess Temple environment. I’m not even able to get through shader compile without the Device Hung / Removed error. Small projects seem to do just fine (e.g., templates).

It’s not an EA2 problem because I just built the current 5.0.0 from GitHub, and it behaves the same way.

Not sure if this is an Epic, Nvidia or Microsoft problem.

Ran Valley of Ancients completely fine previously but now I get this crash every time I enter the dark world. - Except when I run as standalone, only happens when running as PIE it seems

A few months ago it was working fine for me but not sure what specifically caused the issue.

Recently updated to Windows 11 so I feel like blaming that however I have another machine, lower spec with a 3060, Win 11 that is able to run it without this crash.

The moment it crashes in the Event viewer it says:
“Display driver nvlddmkm stopped responding and has successfully recovered.”

but it’s not like my screen goes blank or any other apps have any issue, just the UE5 crash from what I can see

FYI, my issue is the same (Event ID 4101), on Windows 11 only, with a 3090, on all nvidia drivers since W11 release to the current version 479.09, on both the Studio and Game Ready driver branches. Also, it doesn’t have to be Valley of the Ancients. Enabling raytracing in Project Settings seems to make it worse.

PS: I’m also using a source build of the engine current to December 5, so it’s not an EA specific issue.

1 Like

Just ran it for the first time since July and can confirm that this is happening to me too. Running an i9-10920X and RTX 3090 FTW3 in Windows 11.

Reinstalled the drivers so highly doubt that’s the cause. It’s happening to me in the dev environment as well as my compiled build.

i have been facing this issue since a week, unable to fix it can someone please help.

with error DXGI_ERROR_DEVICE_REMOVED with Reason: DXGI_ERROR_DEVICE_HUNG). I have a 3080TI and a ryzen 7 5800x. I’am working on a project of my own. however the temple scene is also crashing in ue5 with the same error.

Got the same error, it seems like a bug in the project(s) or the UE5 engine - since there is a “hardcoded” reference to the D: drive - something that is clearly not on the computer.

I get this error in a level that I added to the CitySample project… and i also got the D3D dump “playing” the small city level.

Also I noticed that I get a “red text” message, that goes something like “out of skin cash memory needs something … so perhaps there is some skincash setting that needs to be adjusted?? I am trying to set it to 296 from 148, but it looks like the value is reset when I open a level or the project… changing amount of MB is not working, i set it to 160 (as recommended elsewhere, but the value seems to be fixed on 148.

( Also it seems the navmesh setting/display (toggle with P dones nothing in any level?) is broken? - it appears that the color displayed for navigation was changed (P) :slight_smile: - I simply did not see that was happening, I just saw the editor being odd. )