Download

Running standalone on Vive VR

I want to run in standalone rather than VR Preview with Vive and can’t get it to work.

What command line options do we need to enable that?

We can run with command line “-fullscreen” or hit alt-enter once you launch. Have not found a config setup that will do this.

Hi Jeff -

Mirrored this over on the SteamVR forums, but putting here for completeness:

  • Start with the -fullscreen commandline
  • Put a ConsoleCommand in your level / game mode blueprint that calls “stereo on”
  • You can edit your packaged build’s UE4CommandlLine.txt to include the -fullscreen command

We tend to roll with option 2, because that allows a little more control.

Thanks Nick, I can confirm both methods 1 and 2 work fine for me.

None of these work for me in 4.13

Try the -vr commandline option. There is also a new project setting under Project Settings :: Description :: Settings, “start in VR”, that will force the equivalent regardless of whether -vr was passed.

There is also ‘Start in VR’ flag in Project Settings. It works for me both in 4.13 and 4.14.