Run EQS Query never ends

Hello, guys! Please help me find where i am wrong.

I have very simple Behavior Tree with EQS for my tests:


FindPlayerCharacter is more simple than that, it just returns ActorsOfClass, without any tests.
When I start simulation and watch my Behavour Tree, I see that Run EQS Query node is nevers ends, and in the same time Balckboard key “Enemy” had a value:

And Wait node is never called!

I used Visual Logger for debug, and see the following log:


Any ideas?

It looks like it should work. The only thing that catches my eye is that you’re using a Sequence as your tree’s runtime root node (the node labels “ROOT” is just an editor thing). Try adding a Selector that will act as a root and plug the sequence under it. Let me know if it works, this might be a bug.



Hi, Mieszko! Thanks for the reply.
Adding Selector node after Sequence did not help me. I used Gameplay Debugger (by the way i have issue with that Gameplay Debugger and Numpad - AI - Unreal Engine Forums) and saw, that my ai character has 0 Queries.
I created “Environment Query System Quick Start Guide” example and here all works great and Gameplay Debugger shows me 2 active queries. So i’m think i do something wrong.

Hey lun,

I ran a quick test with a Find Player EQS I created and the same Behavior Tree setup as you, but I was unable to reproduce the issue.

Could you please attempt to reproduce this in a clean project and then provide a detailed list of steps we can follow to see the issue on our end?


Hello, Sean! Thanks for yourt replay and sorry for the delay from my side.

It’s all works great in clean project, that’s my problem. I’m totally sure, it’s not the UE4 bug, but mine. And I don’t how where to find it. I was no able to use gameplay debugger, because my keyboard doesn’t have numpad keys (ha). Now I have second keyboard and start to debug more deeply.

I found the problem, as I said, it was in my side. My AIController_BP inherited from c++ class. And inside it I had UBlackboardComponent and UBehaviorTreeComponent with no reason. Removing them solved my problem.