Download

RTX on GTX cards

So, after playing with this for a few minutes, I’ve noticed that it’s… definitely not stable at all. I’m honestly a bit surprised that it works at all, though, since the driver is still literally only several hours old, and I imagine there are probably significant implementation differences even if the GTX version implements the same specification in principal. I’m guessing that Epic hasn’t had a chance to do QA against this driver, either.

That said, between crashes I’ve gotten some results that suggest this may actually be usable in real time, which seems crazy. I’m working on a game that uses almost exclusively static lighting, so the GI/AO features aren’t really that relevant for me, but it would be fantastic if I could use DXR as a replacement to SSR for soft reflections.

Have you performed a clean install? I also had crashes and problems until I reinstalled the driver and ticked the “Clean install” button.

Can confirm same results as stated by amoser. What’s interesting is that on my GTX1080, if the only raytraced thing are shadows, then it actually runs pretty well. I have to test GI more, but reflections seems to be the issue right now, with my gpu driver crashing often. Also I don’t know if it’s me not knowing fully what I’m doing or Unreal, but ray-traced reflections look REALLY noisy, like the denoiser is not on.

Been testing it a bit on 1080 TI. The device driver crashes from time to time.

Shadows works rather well. And it’s awesome to finally see shadows without leaks. AO and Skylight shadows seems to give a bit less stable result.
PS: PixelDepthOffset on materials seems to not work very well with ray tracing at the moment.

So for some it might be worth looking into ray tracing the sun’s shadows but nothing else on GTX hardware.

Worked on a 1080ti rendering a very heavy scene (200k trees, 8k landscape etc…). Just make sure your Skylight is set to movable and turn on the raytracing in the skylight. Also turn on Global illumination in the post processing volume.
This will kill your frame rate but good enough for rendering.

Just in case anyone in similar situation -
I have rig (used for rendering in Octane, Iray, etc)
1st slot mobo GPU - Maxwell Titan X,
3rd slot mobo GPU - Titan XP
External - 6 Pascal Titan X

I tried enabled raytracing in 4.22 - used special initialization -dx12 command, verified it as active in Output Log, and selected raytracing in Project Settings menu - that should be it, or do you need special commands to turn features of raytracing on/off? Like, how do you even turn Denoiser on-off?

It didn’t do anything, showed normal raster rendering.
Maybe if I put my Titan Xp as the main mobo and did not have the Maxwell Titan X attached it would possibly work under this new paradigm I am thinking…)

It worked out of the box, I didn’t need to play with cvars to get a basic setup working. Just need to make sure you run in DX12 mode and set your lighting for raytracing.
You might need to tweak some cvars to fine tune your rendering if the parameters already exposed aren’t enough.

Super crash happy on my 1080ti almost unusable, but from what I was able to use it is awesome. Hopefully new driver comes out fixing the crash happy

Can confirm, moved out Titan X Maxwell from Slot 1 and replaced with Titan Xp - I now do have Raytracing!!!
Next trial will be to put a Titan X Pascal in slot 3 to see if functionality remains.

@Klass - thanks!

Anyone,
Is there a list of CVars (Command Variables) for the raytracer?
This isn’t as UI-friendly yet so it is likely not obvious to everyone, I had to deduce it was in the Post Processing from some outside online thread and the -dx12 command from another post in another application’s forum.
I still have no idea how to enable denoiser…LOL

I’m quite happy with the shadow quality. Runs ok-ish on a 1080 TI. (Just remember to disable reflections and ao if you aren’t using it)

As far as I can tell RT shadows have a pixel cost, but not much of a cost in terms of scale. So you get the same quality shadows from a big mountain far away, or a tiny object if you are zoomed in.
So it takes over for both CSM and Distance Field shadows.

UE4 Shadows - Imgsli (CSM doesn’t play nice with one sided objects)
UE4 Shadows - Imgsli

Can confirm, running 2 Pascals on mobo created no issue with Raytracing on the Slot 1 Card.
So, having a 2nd DXR eligible card on the motherboard presented no issue.
Raytracing only works/runs on the first
Slot 1) Titan Xp
Slot 3) Titan X Pascal

(thx Nilson Lima for suggestion earlier in thread)

What is going on with the ability to zoom, when Raytracing it is limited.
?

Confirming everything works on my measly 1060 6GB. No issues with getting it set up, once I updated to Windows 1809 and the latest DXR-enabled driver.

This article is super useful for anyone dealing with trying to get any of the features to run at interactive framerates(at the very least): https://devblogs.nvidia.com/introduction-ray-tracing-unreal-engine-422/

Rendering seems to struggle the most with shadows, but reflections on Titan Xp are so so so so close to being realtime…like in micro seconds…:cool:

Q - Is there actually a denoiser on-off thing? or was that just a development thing, where it is in fact on all the time now.
(There is no option for it in Post Processing like for all the other features.)

You’ll find a bunch of additional settings for each feature with cvars. Just start typing in the console: *raytracing. *and you’ll see all the options. The Post-Process Volume just controls a couple of things, which are also available as cvars.

raytracing skylight has too much noise
its not usable for gtx :(:(:(:frowning:

There is a PDF which with all cvars regarding ray-tracing here : &d=1551711444
Denoiser is enabled by default, I had to crank up the number of samples in the post process volume (global illumination) and the Skylight. I used around 8 samples per pixel for the skylight and 4 sample for the GI. It will kill your frame rate (on a 1080ti).
Maybe you can find the right balance by tweaking the cvars for your scene.

How do you know which drivers to get for 1080ti that support dxr? I have that game nvidia thing and just updated the drivers…

i’m getting a weird dark reflection with a falloff… and stretched reflections. When the camera is closest to the object it seems to be working…Anyone else get that?

will report back with stills and my progress. Just doing a chrome sphere on top of a box.

reflection captures should not change the reflection right? If so, its likely something isn’t setup correctly with the raytracing, and im just watching vanilla reflections? if I delete the reflection capture, the reflection shifts.

pix;

seems like its working, trying to dial in Post Pro box settings… but it seems like the screen is dictating the reflections. The closer I get to the mirror, it beings occluding.

Those are not RT reflections, they are the standard screen-space ones. Make sure to follow the instructions to enable DXR: https://docs.unrealengine.com/en-us/Engine/Rendering/RayTracing

lol… Oh my lord. I feel amazingly daft. Thank you for this response.

Well that explains why when the screen was closer, there was some dark mask happening… as if its taking the space, of the screen… kicks self

I mean, I did the following;

  1. 4.22 installed.

  2. Windows 1809 installed.

  3. Latest 1080ti Drivers ( Maybe there is another source, but I downloaded the latest ones from Nvidia, are there specific ones? I went from nvidias blog, to the site. Did the Game Ready Drivers, then downloaded just the latest drivers from Nvidia) Dxdiag says Dx12.

  4. Create shortcut.
    My desktop shortcut does have " "'s around it so its “path.Unrealengine.exe” -dx12
    I noticed in the documentation, their windows paths don’t have quotes. It throws an error about not being able to find the path if I remove the quotes. Not sure if thats relevant.

  5. Launch ue4.

  6. In project settings, Turn on raytracing. Which thin asks about the skin cache, I say yes. Then it restarts.

  7. Console, to see DXR 12 is installed. It matched the documentation. “LogInit: Command Line: -dx12” etc.

  8. Thats where I’m left at. SSR’s and an embarrassed look on my face. I’ve never tried to make a mirror without having reflection captures planar/cube. So thats why I thought it was working – but it should have dawned on me earlier. As post processing isn’t affecting AO/GI anything raytraced. I’m getting no light bounce. Bah. Stupid.

Last night i noticed I didn’t see the “Raytracing” tab or the Path Tracer under the Lit button in the Perspective viewport.

I installed 4.22, updated windows to 1809, enabled raytracing, restarted it…

unless you have to then further activate raytracing (outside of just hitting enable/restarting)? I’m missing some step. do you have to cut it on, with r.Raytracing 1? I mean documentation just says enabling should be it. Perhaps I am missing something?