RTX Enabled but No Raytracing

Per the realtime raytracing instructions I have:

  1. My project running in 4.22.0
  2. Command line flag for running DX12 (verified UE4 is running DX12)
  3. Raytracing Enabled for my project
  4. System has a RTX 2080 GPU

That being said…it doesn’t appear that raytracing is actually working. I don’t have Raytraced shadows (#1 & #2) and I don’t see the raytracing debug view (#3).

I have no clue why raytracing isn’t working.

Are you using the newest versions of Windows and graphics card drivers ?

Video drivers are up-to-date.

After running Win + R = winver , it appears that I was running build 1803 (OS build 17134.706). After reading the documentation, it looks like the minimum requirement is build 1809. After manually forcing the update, it appears that all the RTX features in UE4 are re-enabled.

So is it working now ?

Yes. It appears that if you’re running a Win10 build prior to 1809, some of the Raytracing settings will appear in engine, however, they won’t actually work. You have to run Win 10 build 1809 (or later).

For a summary, this is what’s needed:

  1. RTX Card (DX12 Supported)
  2. Win 10 Build 1809 (or later)
  3. Command line “-dx12” added to Engine Shortcut
  4. “Raytracing” Enabled in Project Settings

I have been struggling with this same problem for a couple of days. Eventually I looked in the logs and searched for ‘Raytracing’ and found the line:

LogD3D12RHI: Warning: Ray Tracing is disabled because the RenderDoc plugin is currently not compatible with D3D12 ray tracing.

I disabled RenderDoc in the project, and ray tracing began to work.

3 Likes

Thank you!

1 Like