Download

RTX 2080 Super, slow on editor

I have a laptop with internal GTX 1080 installed. It runs normal in editor. And today I bought an EGPU case and an RTX 2080 Super. When I run the editor with my external RTX 2080, in some scenes, some angles, the editor runs with low fps (slower than with GTX 1080) while NOT in game, but when I click play, even if it is PIE the frame rate comes back to normal. There is no code in level about tweaking the frame rates, such as r.ScreenPercentage.

For example from a specific angle (the slowest point of the level and the resolution is 2560x1440), while GTX 1080 gives around 50 frames, RTX 2080 gives 34 frames. Until I hit play. Is it normal for RTX 2080 to run significantly slower than GTX 1080 in editor? What can be the reason?

It might be because it’s an external GPU

I forgot to mention that for most other cases the RTX 2080 is running faster than GTX 1080 including benchmarks and my other Unreal projects. So the situation I posted is happening as some rare exceptions.

That example is on an Unreal 4.19 project. The other projects with more recent Unreal versions work better.

What are your settings in the Nvidia Control Panel? There’s some settings there for configuring which GPU to use, I know in cases where you have a laptop with an integrated Intel GPU along with an Nvidia GPU it will by default try to choose which GPU to use for each program and it does a bad job where it requires setting the Nvidia GPU for everything.

I just checked and saw there is CUDA - GPU selection of either or both GPUs, OpenGL rendering GPU, and for Physics. I tried all combinations and none of it changed the frame rate.

Might be hitting some sort of memory bandwidth bottleneck.

Here’s a shot of the system performance while the low frame rate scene is active on Windows. The GPU memory and the RAM seems fine.