roughness map from substance painter doesn't seem to work right

In a scene I’m working on, I have textured metal doors with a brushed aluminum material in substance painter. I exported with the metal rough preset and in unreal the roughness map doesn’t appear to work as expected. Rather than getting the rough look I’m after, I’m getting a mirror finish. It’s like this on all materials too, not just the metal one. I tried piping the roughness map into the material’s specular channel instead and it looks much closer to what I’m seeing in SP. So I’m wondering if this is normal or if I’m doing something wrong? To illustrate the issue, in the attached image the door frames are using the roughness map in the roughness channel. But the window frames on the side have it going through the spec channel.

1 Like

Can’t be 100% sure this is your problem but based on my own experience with substance, I’d say you have sRGB enabled in your texture settings in UE4. Disable it for roughness.

If the roughness channel is channel packed then use the “Masks” compression setting preset

Allegorithmic/Adobe has a documentation page with a convenient table that tells you the necessary settings for each map:

2022.01.05 Edit: Adobe seems to have deleted the documentation page and expects you to use the plugin from now on. If you still want to do manual import the only thing you really need to know is that sRGB should be enabled for Albedo and disabled for all non-color data such as roughness/metalness/displacement.

1 Like

Try to multiply the texture by a constant then plug the result in the the material input (Roughness), manipulate the constant until you get the desired look. looking at your screenshot I would say it would be between 2 and 3 a very dark roughness might be the cause of the mirror look. if this doesn’t work. Please do share a screenshot of the texture or the material setup you made and we might find the problem.

You should show what the textures themselves look like.

Yes, this seemed to be the issue. It looks much better now. Thanks!

1 Like